Skip to content

← Actionable
Critical, CVSS 9.8amended

@vitejs/plugin-rsc Remote Code Execution through unsafe dynamic imports in RSC server function APIs on development server

CVE-2025-67489GHSA-j76j-5p5g-9wfr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vitejs/plugin-rsc 0.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-67489: 0.81% estimated exploitation activity in the next 30 days; percentile 56.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Arbitrary Remote Code Execution on development server via unsafe dynamic imports in @vitejs/plugin-rsc server function APIs (loadServerAction, decodeReply, decodeAction) when integrated into RSC applications that expose server function endpoints. Impact Attackers with network access to the development server can execute arbitrary JavaScript code with Node.js privileges, allowing them to read/modify files, exfiltrate sensitive data (source code, environment variables, credentials), or pivot to other internal services. While this affects development servers only, the risk increases when using vite --host to expose the server on all network interfaces. Details In the example RSC application provided in Proof of Concept, the server handles server function call through API such as loadServerAction, decodeReply, decodeAction with http request's header and body as inputs:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j76j-5p5g-9wfr

  2. Revision 2 · amended ·

    Amended from osv record GHSA-j76j-5p5g-9wfr

  3. Revision 1 · created ·

    Published from ghsa record GHSA-j76j-5p5g-9wfr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-67489

Advisory: @vitejs/plugin-rsc Remote Code Execution through unsafe dynamic imports in RSC server function APIs on development server
IDs: CVE-2025-67489, GHSA-j76j-5p5g-9wfr
Record: https://patchnext.com/advisories/cve-2025-67489 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @vitejs/plugin-rsc 0.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @vitejs/plugin-rsc: affected <= 0.5.5; fixed in 0.5.6

## Suggested inspection (read-only)
- `npm ls @vitejs/plugin-rsc --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @vitejs/plugin-rsc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j76j-5p5g-9wfr (GitHub-reviewed advisory GHSA-j76j-5p5g-9wfr lists affected ranges: npm @vitejs/plugin-rsc >=0 <=0.5.5)
- Verified: https://osv.dev/vulnerability/GHSA-j76j-5p5g-9wfr (OSV record GHSA-j76j-5p5g-9wfr lists affected ranges: npm @vitejs/plugin-rsc >=0 <0.5.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…