ComfyUI-Manager has an Unprotected Alternate Channel (CWE-420)
CVE-2025-67303GHSA-95pq-hr8p-f5g7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (comfyui-manager 3.38), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI comfyui-manager
- Affected
- < 3.38
- Fixed in
- 3.38
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-95pq-hr8p-f5g7 lists affected ranges: PyPI comfyui-manager >=0 <3.38 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-95pq-hr8p-f5g7 lists affected ranges: PyPI comfyui-manager >=0 <3.38
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2025-67303: 1.39% estimated exploitation activity in the next 30 days; percentile 72.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An Unprotected Alternate Channel (CWE-420) vulnerability was discovered in ComfyUI-Manager versions prior to 3.38. Vulnerability Details In affected versions, ComfyUI-Manager stored its configuration in the user/default/ComfyUI-Manager/ directory, which was accessible via ComfyUI's web APIs without proper access control. This unprotected alternate channel allowed remote attackers to read and manipulate configuration files and critical data through the web interface. Potential Attack Scenarios An attacker exploiting this vulnerability could: - Modify security settings: Lower the security level from "strong" to "weak" to enable more dangerous operations - Tamper with custom node sources: Add malicious custom node repositories - Manipulate snapshot data: Corrupt or alter system snapshots - Change manager behavior: Alter various manager configuration settings Affected Configurations | Configuration | Risk Level | |---------------|------------| | Systems running with --listen…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-95pq-hr8p-f5g7
- Revision 1 · created ·
Published from osv record GHSA-95pq-hr8p-f5g7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-67303 Advisory: ComfyUI-Manager has an Unprotected Alternate Channel (CWE-420) IDs: CVE-2025-67303, GHSA-95pq-hr8p-f5g7 Record: https://patchnext.com/advisories/cve-2025-67303 (revision 2, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: comfyui-manager 3.38. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI comfyui-manager: affected < 3.38; fixed in 3.38 ## Suggested inspection (read-only) - `python -m pip show comfyui-manager`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on comfyui-manager. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-95pq-hr8p-f5g7 (OSV record GHSA-95pq-hr8p-f5g7 lists affected ranges: PyPI comfyui-manager >=0 <3.38 (fixed)) - Verified: https://github.com/advisories/GHSA-95pq-hr8p-f5g7 (GitHub-reviewed advisory GHSA-95pq-hr8p-f5g7 lists affected ranges: PyPI comfyui-manager >=0 <3.38) Commands are suggestions: review each one before running it.
Loading voting…