ImageMagick is vulnerable to an integer Overflow in TIM decoder leading to out of bounds read (32-bit only)
CVE-2025-66628GHSA-6hjr-v6g4-3fm8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (magick.net-q8-x86 14.10.0; magick.net-q16-hdri-anycpu 14.10.0; magick.net-q16-anycpu 14.10.0; magick.net-q16-hdri-x86 14.10.0; magick.net-q16-x86 14.10.0; 1 more package under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet magick.net-q8-x86
- Affected
- < 14.10.0
- Fixed in
- 14.10.0
NuGet magick.net-q16-hdri-anycpu
- Affected
- < 14.10.0
- Fixed in
- 14.10.0
NuGet magick.net-q16-anycpu
- Affected
- < 14.10.0
- Fixed in
- 14.10.0
NuGet magick.net-q16-hdri-x86
- Affected
- < 14.10.0
- Fixed in
- 14.10.0
NuGet magick.net-q16-x86
- Affected
- < 14.10.0
- Fixed in
- 14.10.0
NuGet magick.net-q8-anycpu
- Affected
- < 14.10.0
- Fixed in
- 14.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6hjr-v6g4-3fm8 lists affected ranges: NuGet magick.net-q16-anycpu >=0 =0 =0 =0 =0 =0 <14.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-66628: 0.51% estimated exploitation activity in the next 30 days; percentile 43.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The TIM (PSX TIM) image parser in ImageMagick contains a critical integer overflow vulnerability in the ReadTIMImage function (coders/tim.c). The code reads width and height (16-bit values) from the file header and calculates imagesize = 2 width height without checking for overflow. On 32-bit systems (or where sizet is 32-bit), this calculation can overflow if width and height are large (e.g., 65535), wrapping around to a small value. This results in a small heap allocation via AcquireQuantumMemory and later operations relying on the dimensions can trigger an out of bounds read. Vulnerable Code File: coders/tim.c Impact This vulnerability can lead to Arbitrary Memory Disclosure due to an out of bounds read on 32-bit systems.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6hjr-v6g4-3fm8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66628 Advisory: ImageMagick is vulnerable to an integer Overflow in TIM decoder leading to out of bounds read (32-bit only) IDs: CVE-2025-66628, GHSA-6hjr-v6g4-3fm8 Record: https://patchnext.com/advisories/cve-2025-66628 (revision 1, source checked 26 Oct 2026, 17:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: magick.net-q8-x86 14.10.0; magick.net-q16-hdri-anycpu 14.10.0; magick.net-q16-anycpu 14.10.0; magick.net-q16-hdri-x86 14.10.0; magick.net-q16-x86 14.10.0; magick.net-q8-anycpu 14.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet magick.net-q8-x86: affected < 14.10.0; fixed in 14.10.0 - NuGet magick.net-q16-hdri-anycpu: affected < 14.10.0; fixed in 14.10.0 - NuGet magick.net-q16-anycpu: affected < 14.10.0; fixed in 14.10.0 - NuGet magick.net-q16-hdri-x86: affected < 14.10.0; fixed in 14.10.0 - NuGet magick.net-q16-x86: affected < 14.10.0; fixed in 14.10.0 - NuGet magick.net-q8-anycpu: affected < 14.10.0; fixed in 14.10.0 ## Suggested inspection (read-only) - NuGet magick.net-q8-x86: check the installed version with your package manager. - NuGet magick.net-q16-hdri-anycpu: check the installed version with your package manager. - NuGet magick.net-q16-anycpu: check the installed version with your package manager. - NuGet magick.net-q16-hdri-x86: check the installed version with your package manager. - NuGet magick.net-q16-x86: check the installed version with your package manager. - NuGet magick.net-q8-anycpu: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magick.net-q8-x86, magick.net-q16-hdri-anycpu, magick.net-q16-anycpu, magick.net-q16-hdri-x86, magick.net-q16-x86, magick.net-q8-anycpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6hjr-v6g4-3fm8 (GitHub-reviewed advisory GHSA-6hjr-v6g4-3fm8 lists affected ranges: NuGet magick.net-q16-anycpu >=0 =0 =0 =0 =0 =0 <14.10.0) Commands are suggestions: review each one before running it.
Loading voting…