Skip to content

← Actionable
High, CVSS 8.4

Critical Use-After-Free in Wasmi's Linear Memory

CVE-2025-66627GHSA-g4v2-cjqp-rfmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wasmi 1.0.1, 0.51.3, 0.47.1, 0.41.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io wasmi

    Affected
    >= 0.41.0, < 0.41.2>= 0.42.0, < 0.47.1>= 0.50.0, < 0.51.3>= 1.0.0, < 1.0.1
    Fixed in
    0.47.1, 0.41.2, 0.51.3, 1.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-66627: 0.15% estimated exploitation activity in the next 30 days; percentile 3.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A use-after-free vulnerability has been discovered in the linear memory implementation of Wasmi. This issue can be triggered by a WebAssembly module under certain memory growth conditions, potentially leading to memory corruption, information disclosure, or code execution. Impact - Confidentiality: High – attacker-controlled memory reads possible. - Integrity: High – memory corruption may allow arbitrary writes. - Availability: High – interpreter crashes possible. Affected Versions Wasmi v0.41.0 through Wasmi v1.0.0. Workarounds - Upgrade to the latest patched version of Wasmi. - Consider limiting the maximum linear memory sizes where feasible. Credits This vulnerability was discovered by Robert T. Morris (RTM).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g4v2-cjqp-rfmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66627

Advisory: Critical Use-After-Free in Wasmi's Linear Memory
IDs: CVE-2025-66627, GHSA-g4v2-cjqp-rfmq
Record: https://patchnext.com/advisories/cve-2025-66627 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wasmi 1.0.1, 0.51.3, 0.47.1, 0.41.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io wasmi: affected >= 0.41.0, < 0.41.2; >= 0.42.0, < 0.47.1; >= 0.50.0, < 0.51.3; >= 1.0.0, < 1.0.1; fixed in 0.47.1, 0.41.2, 0.51.3, 1.0.1

## Suggested inspection (read-only)
- crates.io wasmi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wasmi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g4v2-cjqp-rfmq (GitHub-reviewed advisory GHSA-g4v2-cjqp-rfmq lists affected ranges: crates.io wasmi >=0.41.0 =0.42.0 =0.50.0 =1.0.0 <1.0.1)

Commands are suggestions: review each one before running it.

Loading voting…