Apache Tomcat - Client certificate verification bypass
CVE-2025-66614GHSA-fpj8-gq4v-p354
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-coyote
- Affected
- >= 11.0.0-M1, < 11.0.15>= 10.1.0-M1, < 10.1.50>= 9.0.0-M1, < 9.0.113>= 8.5.0, <= 8.5.100
- Fixed in
- 11.0.15, 9.0.113, 10.1.50
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.0-M1, < 11.0.15>= 10.1.0-M1, < 10.1.50>= 9.0.0-M1, < 9.0.113>= 8.5.0, <= 8.5.100
- Fixed in
- 11.0.15, 9.0.113, 10.1.50
Maven org.apache.tomcat:tomcat
- Affected
- >= 11.0.0-M1, < 11.0.15>= 10.1.0-M1, < 10.1.50>= 9.0.0-M1, < 9.0.113>= 8.5.0, <= 8.5.100
- Fixed in
- 11.0.15, 9.0.113, 10.1.50
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fpj8-gq4v-p354 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 <=8.5.100
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-66614: 0.27% estimated exploitation activity in the next 30 days; percentile 19.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Older EOL versions are not affected. Tomcat did not validate that the host name provided via the SNI extension was the same as the host name provided in the HTTP host header field. If Tomcat was configured with more than one virtual host and the TLS configuration for one of those hosts did not require client certificate authentication but another one did, it was possible for a client to bypass the client certificate authentication by sending different host names in the SNI extension and the HTTP host header field. The vulnerability only applies if client certificate authentication is only enforced at the Connector. It does not apply if client certificate authentication is enforced at the web…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fpj8-gq4v-p354
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66614 Advisory: Apache Tomcat - Client certificate verification bypass IDs: CVE-2025-66614, GHSA-fpj8-gq4v-p354 Record: https://patchnext.com/advisories/cve-2025-66614 (revision 1, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-coyote 11.0.15, 10.1.50, 9.0.113; org.apache.tomcat.embed:tomcat-embed-core 11.0.15, 10.1.50, 9.0.113; org.apache.tomcat:tomcat 11.0.15, 10.1.50, 9.0.113. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-coyote: affected >= 11.0.0-M1, < 11.0.15; >= 10.1.0-M1, < 10.1.50; >= 9.0.0-M1, < 9.0.113; >= 8.5.0, <= 8.5.100; fixed in 11.0.15, 9.0.113, 10.1.50 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.15; >= 10.1.0-M1, < 10.1.50; >= 9.0.0-M1, < 9.0.113; >= 8.5.0, <= 8.5.100; fixed in 11.0.15, 9.0.113, 10.1.50 - Maven org.apache.tomcat:tomcat: affected >= 11.0.0-M1, < 11.0.15; >= 10.1.0-M1, < 10.1.50; >= 9.0.0-M1, < 9.0.113; >= 8.5.0, <= 8.5.100; fixed in 11.0.15, 9.0.113, 10.1.50 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fpj8-gq4v-p354 (GitHub-reviewed advisory GHSA-fpj8-gq4v-p354 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 <=8.5.100) Commands are suggestions: review each one before running it.
Loading voting…