Skip to content

← Actionable
Critical, CVSS 9.3

Ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)

CVE-2025-66567GHSA-9v8j-x534-2fx3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ruby-saml 1.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems ruby-saml

    Affected
    < 1.18.0
    Fixed in
    1.18.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-66567: 0.42% estimated exploitation activity in the next 30 days; percentile 36.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Ruby-saml up to and including 1.12.4, there is an authentication bypass vulnerability because of an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, the parsers can generate entirely different document structures from the same XML input. That allows an attacker to be able to execute a Signature Wrapping attack. The vulnerability does not affect the version 1.18.0. Impact That allows an attacker to be able to execute a Signature Wrapping attack and bypass the authentication

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9v8j-x534-2fx3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66567

Advisory: Ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)
IDs: CVE-2025-66567, GHSA-9v8j-x534-2fx3
Record: https://patchnext.com/advisories/cve-2025-66567 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ruby-saml 1.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems ruby-saml: affected < 1.18.0; fixed in 1.18.0

## Suggested inspection (read-only)
- RubyGems ruby-saml: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ruby-saml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9v8j-x534-2fx3 (GitHub-reviewed advisory GHSA-9v8j-x534-2fx3 lists affected ranges: RubyGems ruby-saml >=0 <1.18.0)

Commands are suggestions: review each one before running it.

Loading voting…