Skip to content

← Actionable
High, CVSS 8.2

yawkat LZ4 Java has a possible information leak in Java safe decompressor

CVE-2025-66566GHSA-cmp6-m4wj-q63q

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven net.jpountz.lz4:lz4

    Affected
    <= 1.8.1
    Fixed in
    no fixed version recorded
  • Maven org.lz4:lz4-pure-java

    Affected
    <= 1.8.1
    Fixed in
    no fixed version recorded
  • Maven at.yawk.lz4:lz4-java

    Affected
    <= 1.10.0
    Fixed in
    1.10.1
  • Maven org.lz4:lz4-java

    Affected
    <= 1.8.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-66566: 0.60% estimated exploitation activity in the next 30 days; percentile 49.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Insufficient clearing of the output buffer in Java-based decompressor implementations in lz4-java 1.10.0 and earlier allows remote attackers to read previous buffer contents via crafted compressed input. In applications where the output buffer is reused without being cleared, this may lead to disclosure of sensitive data. JNI-based implementations are not affected. Details During the decompression process, the lz4 algorithm may have to repeat data that was previously decompressed in the same input frame. In the Java implementation, this is implemented by copy operations within the output buffer. With a crafted input, an attacker may induce the Java implementation to copy from a region in the output buffer that does not contain decompressed data yet. If that region contains sensitive information because the output buffer was not cleared prior to decompression, that data will then be copied to the decompressed output. - LZ4Factory.nativeInstance().safeDecompressor() is not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cmp6-m4wj-q63q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66566

Advisory: yawkat LZ4 Java has a possible information leak in Java safe decompressor
IDs: CVE-2025-66566, GHSA-cmp6-m4wj-q63q
Record: https://patchnext.com/advisories/cve-2025-66566 (revision 1, source checked 26 Oct 2026, 16:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: at.yawk.lz4:lz4-java 1.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven net.jpountz.lz4:lz4: affected <= 1.8.1
- Maven org.lz4:lz4-pure-java: affected <= 1.8.1
- Maven at.yawk.lz4:lz4-java: affected <= 1.10.0; fixed in 1.10.1
- Maven org.lz4:lz4-java: affected <= 1.8.1

## Suggested inspection (read-only)
- Maven net.jpountz.lz4:lz4: check the installed version with your package manager.
- Maven org.lz4:lz4-pure-java: check the installed version with your package manager.
- Maven at.yawk.lz4:lz4-java: check the installed version with your package manager.
- Maven org.lz4:lz4-java: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on net.jpountz.lz4:lz4, org.lz4:lz4-pure-java, at.yawk.lz4:lz4-java, org.lz4:lz4-java.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cmp6-m4wj-q63q (GitHub-reviewed advisory GHSA-cmp6-m4wj-q63q lists affected ranges: Maven at.yawk.lz4:lz4-java >=0 =0 =0 =0 <=1.8.1)

Commands are suggestions: review each one before running it.

Loading voting…