1Panel – CAPTCHA Bypass via Client-Controlled Flag
CVE-2025-66507GHSA-qmg5-v42x-qqhq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/1Panel-dev/1Panel/core 0.0.0-20251128030527-ac43f00273be; github.com/1Panel-dev/1Panel 2.0.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/1Panel-dev/1Panel/core
- Affected
- < 0.0.0-20251128030527-ac43f00273be
- Fixed in
- 0.0.0-20251128030527-ac43f00273be
Go github.com/1Panel-dev/1Panel
- Affected
- < 2.0.14
- Fixed in
- 2.0.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qmg5-v42x-qqhq lists affected ranges: Go github.com/1Panel-dev/1Panel >=0 =0 <0.0.0-20251128030527-ac43f00273be
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-66507: 0.46% estimated exploitation activity in the next 30 days; percentile 40.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A CAPTCHA bypass vulnerability in the 1Panel authentication API allows an unauthenticated attacker to disable CAPTCHA verification by abusing a client-controlled parameter. Because the server previously trusted this value without proper validation, CAPTCHA protections could be bypassed, enabling automated login attempts and significantly increasing the risk of account takeover (ATO). Details The /api/login endpoint accepts a boolean field named ignoreCaptcha directly from the client request body: "ignoreCaptcha": true The backend implementation uses this value to determine whether CAPTCHA validation should be performed: Because req.IgnoreCaptcha is taken directly from user input—with no server-side validation, no session binding, and no privilege checks—any unauthenticated attacker can force CAPTCHA validation to be skipped. There are no additional conditions, such as: no requirement for MFA no trusted device no IP reputation checks no prior valid session no rate limiting…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qmg5-v42x-qqhq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66507 Advisory: 1Panel – CAPTCHA Bypass via Client-Controlled Flag IDs: CVE-2025-66507, GHSA-qmg5-v42x-qqhq Record: https://patchnext.com/advisories/cve-2025-66507 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/1Panel-dev/1Panel/core 0.0.0-20251128030527-ac43f00273be; github.com/1Panel-dev/1Panel 2.0.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/1Panel-dev/1Panel/core: affected < 0.0.0-20251128030527-ac43f00273be; fixed in 0.0.0-20251128030527-ac43f00273be - Go github.com/1Panel-dev/1Panel: affected < 2.0.14; fixed in 2.0.14 ## Suggested inspection (read-only) - Go github.com/1Panel-dev/1Panel/core: check the installed version with your package manager. - Go github.com/1Panel-dev/1Panel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/1Panel-dev/1Panel/core, github.com/1Panel-dev/1Panel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qmg5-v42x-qqhq (GitHub-reviewed advisory GHSA-qmg5-v42x-qqhq lists affected ranges: Go github.com/1Panel-dev/1Panel >=0 =0 <0.0.0-20251128030527-ac43f00273be) Commands are suggestions: review each one before running it.
Loading voting…