Anthropic Sandbox Runtime Incorrectly Implemented Network Sandboxing
CVE-2025-66479GHSA-9gqj-5w7c-vx47
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@anthropic-ai/sandbox-runtime 0.0.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @anthropic-ai/sandbox-runtime
- Affected
- < 0.0.16
- Fixed in
- 0.0.16
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9gqj-5w7c-vx47 lists affected ranges: npm @anthropic-ai/sandbox-runtime >=0 <0.0.16 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9gqj-5w7c-vx47 lists affected ranges: npm @anthropic-ai/sandbox-runtime >=0 <0.0.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-66479: 0.16% estimated exploitation activity in the next 30 days; percentile 5.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Due to a bug in sandboxing logic, sandbox-runtime did not properly enforce a network sandbox if the sandbox policy did not configure any allowed domains. This could allow sandboxed code to make network requests outside of the sandbox. A patch for this was released in v0.0.16. Thank you to https://github.com/bendrucker for reporting this issue!
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9gqj-5w7c-vx47
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9gqj-5w7c-vx47
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66479 Advisory: Anthropic Sandbox Runtime Incorrectly Implemented Network Sandboxing IDs: CVE-2025-66479, GHSA-9gqj-5w7c-vx47 Record: https://patchnext.com/advisories/cve-2025-66479 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @anthropic-ai/sandbox-runtime 0.0.16. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @anthropic-ai/sandbox-runtime: affected < 0.0.16; fixed in 0.0.16 ## Suggested inspection (read-only) - `npm ls @anthropic-ai/sandbox-runtime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @anthropic-ai/sandbox-runtime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9gqj-5w7c-vx47 (OSV record GHSA-9gqj-5w7c-vx47 lists affected ranges: npm @anthropic-ai/sandbox-runtime >=0 <0.0.16 (fixed)) - Verified: https://github.com/advisories/GHSA-9gqj-5w7c-vx47 (GitHub-reviewed advisory GHSA-9gqj-5w7c-vx47 lists affected ranges: npm @anthropic-ai/sandbox-runtime >=0 <0.0.16) Commands are suggestions: review each one before running it.
Loading voting…