XWiki vulnerable to remote code execution through insufficient protection against {{/html}} injection
CVE-2025-66474GHSA-9xc6-c2rm-f27p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.rendering:xwiki-rendering-xml 17.6.0-rc-1, 17.4.3, 16.10.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.rendering:xwiki-rendering-xml
- Affected
- < 16.10.10>= 17.0.0-rc-1, < 17.4.3>= 17.5.0-rc-1, < 17.6.0-rc-1
- Fixed in
- 16.10.10, 17.4.3, 17.6.0-rc-1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9xc6-c2rm-f27p lists affected ranges: Maven org.xwiki.rendering:xwiki-rendering-xml >=0 =17.0.0-rc-1 =17.5.0-rc-1 <17.6.0-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-66474: 1.02% estimated exploitation activity in the next 30 days; percentile 63.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any user who can edit their own user profile or any other document can execute arbitrary script macros including Groovy and Python macros that allow remote code execution including unrestricted read and write access to all wiki contents. The reason is that rendering output is included as content of HTML macros with insufficient escaping, and it is thus possible to close the HTML macro and inject script macros that are executed with programming rights. To demonstrate, the content {{html}}{{/html {{/html}}}} can be inserted into any field of the user profile that supports wiki syntax like the "About" field. If this leads to the display of raw HTML, the instance is vulnerable. Patches This problem has been patched by extending the escaping introduced by XRENDERING-693 to also cover closing HTML macros that have spaces after the macro name in XWiki 16.10.10, 17.4.3 and 17.6.0RC1. A similar fix has been applied in org.xwiki.platform:xwiki-platform-oldcore as an extra safety net,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9xc6-c2rm-f27p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66474
Advisory: XWiki vulnerable to remote code execution through insufficient protection against {{/html}} injection
IDs: CVE-2025-66474, GHSA-9xc6-c2rm-f27p
Record: https://patchnext.com/advisories/cve-2025-66474 (revision 1, source checked 26 Oct 2026, 16:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.rendering:xwiki-rendering-xml 17.6.0-rc-1, 17.4.3, 16.10.10. A vendor fix does not mean a deployment is fixed.
## Affected components
- Maven org.xwiki.rendering:xwiki-rendering-xml: affected < 16.10.10; >= 17.0.0-rc-1, < 17.4.3; >= 17.5.0-rc-1, < 17.6.0-rc-1; fixed in 16.10.10, 17.4.3, 17.6.0-rc-1
## Suggested inspection (read-only)
- Maven org.xwiki.rendering:xwiki-rendering-xml: check the installed version with your package manager.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.rendering:xwiki-rendering-xml.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://github.com/advisories/GHSA-9xc6-c2rm-f27p (GitHub-reviewed advisory GHSA-9xc6-c2rm-f27p lists affected ranges: Maven org.xwiki.rendering:xwiki-rendering-xml >=0 =17.0.0-rc-1 =17.5.0-rc-1 <17.6.0-rc-1)
Commands are suggestions: review each one before running it.Loading voting…