NiceGUI Stored/Reflected XSS in ui.interactive_image via unsanitized SVG content
CVE-2025-66470GHSA-2m4f-cg75-76w2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nicegui 3.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nicegui
- Affected
- <= 3.3.1
- Fixed in
- 3.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2m4f-cg75-76w2 lists affected ranges: PyPI nicegui >=0 <3.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2m4f-cg75-76w2 lists affected ranges: PyPI nicegui >=0 <=3.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2025-66470: 0.25% estimated exploitation activity in the next 30 days; percentile 17.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Cross-Site Scripting (XSS) vulnerability exists in the ui.interactiveimage component of NiceGUI (v3.3.1 and earlier). The component renders SVG content using Vue's v-html directive without any sanitization. This allows attackers to inject malicious HTML or JavaScript via the SVG <foreignObject tag. Details The vulnerability is located in nicegui/elements/interactiveimage.js. The component uses the following code to render content: Vue's v-html directive renders raw HTML strings into the DOM. If an application allows user-controlled input to be passed to the content property of an interactive image, an attacker can embed a <foreignObject tag containing malicious scripts, bypassing typical image restrictions. PoC Impact - Type: Reflected / Stored XSS (depending on data source) - Severity: Moderate - Impact: Attackers can inject malicious scripts that execute whenever the image component is rendered or updated. This is particularly dangerous for dashboards or multi-user…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2m4f-cg75-76w2
- Revision 1 · created ·
Published from osv record GHSA-2m4f-cg75-76w2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66470 Advisory: NiceGUI Stored/Reflected XSS in ui.interactive_image via unsanitized SVG content IDs: CVE-2025-66470, GHSA-2m4f-cg75-76w2 Record: https://patchnext.com/advisories/cve-2025-66470 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nicegui 3.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nicegui: affected <= 3.3.1; fixed in 3.4.0 ## Suggested inspection (read-only) - `python -m pip show nicegui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nicegui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2m4f-cg75-76w2 (OSV record GHSA-2m4f-cg75-76w2 lists affected ranges: PyPI nicegui >=0 <3.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-2m4f-cg75-76w2 (GitHub-reviewed advisory GHSA-2m4f-cg75-76w2 lists affected ranges: PyPI nicegui >=0 <=3.3.1) Commands are suggestions: review each one before running it.
Loading voting…