Skip to content

← Actionable
High, CVSS 7.5amended

Elysia affected by arbitrary code injection through cookie config

CVE-2025-66457GHSA-8vch-m3f4-q8jf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (elysia 1.4.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm elysia

    Affected
    < 1.4.18
    Fixed in
    1.4.18

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-66457: 0.81% estimated exploitation activity in the next 30 days; percentile 56.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Arbitrary code execution from cookie config. If dynamic cookies are enabled (ie there exists a schema for cookies), the cookie config is injected into the compiled route without first being sanitised. Availability of this exploit is generally low, as it requires write access to either the Elysia app's source code (in which case the vulnerability is meaningless) or write access to the cookie config (perhaps where it is assumed to be provisioned by the environment). However when combined with GHSA-hxj9-33pp-j2cc, this vulnerability allows for a full RCE chain. Impact - aot enabled (default) - cookie schema passed to route - Cookie config controllable eg. via env Example of vulnerable code POC: https://github.com/sportshead/elysia-poc Patches Patched by 1.4.17 (https://github.com/elysiajs/elysia/pull/1564) Reference commit: - https://github.com/elysiajs/elysia/pull/1564/commits/26935bf76ebc43b4a43d48b173fc853de43bb51e -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8vch-m3f4-q8jf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8vch-m3f4-q8jf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66457

Advisory: Elysia affected by arbitrary code injection through cookie config
IDs: CVE-2025-66457, GHSA-8vch-m3f4-q8jf
Record: https://patchnext.com/advisories/cve-2025-66457 (revision 3, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: elysia 1.4.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm elysia: affected < 1.4.18; fixed in 1.4.18

## Suggested inspection (read-only)
- `npm ls elysia --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on elysia.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8vch-m3f4-q8jf (OSV record GHSA-8vch-m3f4-q8jf lists affected ranges: npm elysia >=0 <1.4.18 (fixed))
- Verified: https://github.com/advisories/GHSA-8vch-m3f4-q8jf (GitHub-reviewed advisory GHSA-8vch-m3f4-q8jf lists affected ranges: npm elysia >=0 <1.4.18)

Commands are suggestions: review each one before running it.

Loading voting…