Skip to content

← Actionable
Critical, CVSS 9.8amended

LMDeploy has Remote Code Execution by Pickle Deserialization via handle_zmq_recv in lmdeploy/lmdeploy/pytorch/disagg/conn/engine_conn.py

CVE-2025-66455GHSA-2vh9-42vm-xmv2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lmdeploy 0.16.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lmdeploy

    Affected
    >= 0.9.2, < 0.16.0
    Fixed in
    0.16.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-66455: 1.27% estimated exploitation activity in the next 30 days; percentile 69.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary LMDeploy's PyTorch DistServe/PD-disaggregation control plane used recvpyobj() to deserialize messages received through a ZeroMQ PULL socket. PyZMQ implements recvpyobj() using Python pickle deserialization, which can execute arbitrary code while reconstructing an object. The peer address used by the receiver was supplied through the POST /distserve/p2pconnect HTTP endpoint. An attacker who could reach an affected DistServe API server could cause the server to connect to an attacker-controlled ZeroMQ endpoint and deserialize a crafted pickle payload. API-key authentication is not enabled unless the operator explicitly configures it. As a result, affected DistServe deployments without API keys allowed unauthenticated remote code execution with the privileges of the LMDeploy serving process. This issue affects the PyTorch backend when PD-disaggregation/DistServe is enabled. Ordinary deployments that do not use the affected disaggregated-serving path do not expose this data flow.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2vh9-42vm-xmv2

  2. Revision 2 · amended ·

    Amended from osv record GHSA-2vh9-42vm-xmv2

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2vh9-42vm-xmv2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66455

Advisory: LMDeploy has Remote Code Execution by Pickle Deserialization via handle_zmq_recv in lmdeploy/lmdeploy/pytorch/disagg/conn/engine_conn.py
IDs: CVE-2025-66455, GHSA-2vh9-42vm-xmv2
Record: https://patchnext.com/advisories/cve-2025-66455 (revision 3, source checked 26 Oct 2026, 13:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lmdeploy 0.16.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lmdeploy: affected >= 0.9.2, < 0.16.0; fixed in 0.16.0

## Suggested inspection (read-only)
- `python -m pip show lmdeploy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lmdeploy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2vh9-42vm-xmv2 (GitHub-reviewed advisory GHSA-2vh9-42vm-xmv2 lists affected ranges: PyPI lmdeploy >=0.9.2 <0.16.0)
- Verified: https://osv.dev/vulnerability/GHSA-2vh9-42vm-xmv2 (OSV record GHSA-2vh9-42vm-xmv2 lists affected ranges: PyPI lmdeploy >=0.9.2 <0.16.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…