arcade-mcp-server Has Default Hardcoded Worker Secret That Allows Full Unauthorized Access to All HTTP MCP Worker Endpoints
CVE-2025-66454GHSA-g2jx-37x6-6438
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (arcade-mcp-server 1.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI arcade-mcp-server
- Affected
- < 1.9.1
- Fixed in
- 1.9.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g2jx-37x6-6438 lists affected ranges: PyPI arcade-mcp-server >=0 <1.9.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g2jx-37x6-6438 lists affected ranges: PyPI arcade-mcp-server >=0 <1.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-66454: 0.33% estimated exploitation activity in the next 30 days; percentile 26.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The arcade-mcp HTTP server uses a hardcoded default worker secret ("dev") that is never validated or overridden during normal server startup. As a result, any unauthenticated attacker who knows this default key can forge valid JWTs and fully bypass the FastAPI authentication layer. This grants remote access to all worker endpoints—including tool enumeration and tool invocation—without credentials. Anyone following the official quick-start guide is vulnerable unless they manually override ARCADEWORKERSECRET. Details The documented method for launching an HTTP MCP server (python server.py http) implicitly sets the worker secret to the hardcoded default "dev": ArcadeSettings.serversecret defaults to "dev" (libs/arcade-mcp-server/arcademcpserver/settings.py:129–158) createarcademcp() passes this value directly to FastAPIWorker without validation (libs/arcade-mcp-server/arcademcpserver/worker.py:118–188) BaseWorker.setsecret() accepts this value and does not enforce rotation…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g2jx-37x6-6438
- Revision 1 · created ·
Published from osv record GHSA-g2jx-37x6-6438
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66454 Advisory: arcade-mcp-server Has Default Hardcoded Worker Secret That Allows Full Unauthorized Access to All HTTP MCP Worker Endpoints IDs: CVE-2025-66454, GHSA-g2jx-37x6-6438 Record: https://patchnext.com/advisories/cve-2025-66454 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: arcade-mcp-server 1.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI arcade-mcp-server: affected < 1.9.1; fixed in 1.9.1 ## Suggested inspection (read-only) - `python -m pip show arcade-mcp-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on arcade-mcp-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g2jx-37x6-6438 (OSV record GHSA-g2jx-37x6-6438 lists affected ranges: PyPI arcade-mcp-server >=0 <1.9.1 (fixed)) - Verified: https://github.com/advisories/GHSA-g2jx-37x6-6438 (GitHub-reviewed advisory GHSA-g2jx-37x6-6438 lists affected ranges: PyPI arcade-mcp-server >=0 <1.9.1) Commands are suggestions: review each one before running it.
Loading voting…