Angular Stored XSS Vulnerability via SVG Animation, SVG URL and MathML Attributes
CVE-2025-66412GHSA-v4hv-rgfq-gp49
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 21.0.0-next.0, < 21.0.2>= 20.0.0-next.0, < 20.3.15>= 19.0.0-next.0, < 19.2.17<= 18.2.14
- Fixed in
- 19.2.17, 21.0.2, 20.3.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v4hv-rgfq-gp49 lists affected ranges: npm @angular/compiler >=21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v4hv-rgfq-gp49 lists affected ranges: npm @angular/compiler >=21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-66412: 0.38% estimated exploitation activity in the next 30 days; percentile 32.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Stored Cross-Site Scripting (XSS) vulnerability has been identified in the Angular Template Compiler. It occurs because the compiler's internal security schema is incomplete, allowing attackers to bypass Angular's built-in security sanitization. Specifically, the schema fails to classify certain URL-holding attributes (e.g., those that could contain javascript: URLs) as requiring strict URL security, enabling the injection of malicious scripts. Additionally, a related vulnerability exists involving SVG animation elements (<animate, <set, <animateMotion, <animateTransform). The attributeName attribute on these elements was not properly validated, allowing attackers to dynamically target security-sensitive attributes like href or xlink:href on other elements. By binding attributeName to "href" and providing a javascript: URL in the values or to attribute, an attacker could bypass sanitization and execute arbitrary code. Attributes confirmed to be vulnerable include: SVG-related…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v4hv-rgfq-gp49
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v4hv-rgfq-gp49
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66412 Advisory: Angular Stored XSS Vulnerability via SVG Animation, SVG URL and MathML Attributes IDs: CVE-2025-66412, GHSA-v4hv-rgfq-gp49 Record: https://patchnext.com/advisories/cve-2025-66412 (revision 3, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/compiler 21.0.2, 20.3.15, 19.2.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/compiler: affected >= 21.0.0-next.0, < 21.0.2; >= 20.0.0-next.0, < 20.3.15; >= 19.0.0-next.0, < 19.2.17; <= 18.2.14; fixed in 19.2.17, 21.0.2, 20.3.15 ## Suggested inspection (read-only) - `npm ls @angular/compiler --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/compiler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v4hv-rgfq-gp49 (OSV record GHSA-v4hv-rgfq-gp49 lists affected ranges: npm @angular/compiler >=21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14) - Verified: https://github.com/advisories/GHSA-v4hv-rgfq-gp49 (GitHub-reviewed advisory GHSA-v4hv-rgfq-gp49 lists affected ranges: npm @angular/compiler >=21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14) Commands are suggestions: review each one before running it.
Loading voting…