Coder logs sensitive objects unsanitized
CVE-2025-66411GHSA-jf75-p25m-pw74
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/coder/coder/v2 2.28.4, 2.27.7, 2.26.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.26.5>= 2.27.0, < 2.27.7>= 2.28.0, < 2.28.4
- Fixed in
- 2.28.4, 2.27.7, 2.26.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jf75-p25m-pw74 lists affected ranges: Go github.com/coder/coder/v2 >=0 =2.27.0 =2.28.0 <2.28.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-66411: 0.25% estimated exploitation activity in the next 30 days; percentile 16.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Workspace Agent manifests containing sensitive values were logged in plaintext unsanitized Details By default Workspace Agent logs are redirected to stderr https://github.com/coder/coder/blob/a8862be546f347c59201e2219d917e28121c0edb/cli/agent.go#L432-L439 Workspace Agent Manifests containing sensitive environment variables were logged insecurely https://github.com/coder/coder/blob/7beb95fd56d2f790502e236b64906f8eefb969bd/agent/agent.go#L1090 An attacker with limited local access to the Coder Workspace (VM, K8s Pod etc.) or a third-party system (SIEM, logging stack) could access those logs This behavior opened room for unauthorized access and privilege escalation Impact Impact varies depending on the environment variables set in a given workspace Patches Fix was released & backported: - https://github.com/coder/coder/releases/tag/v2.28.4 - https://github.com/coder/coder/releases/tag/v2.27.7 - https://github.com/coder/coder/releases/tag/v2.26.5 Workarounds One potential…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jf75-p25m-pw74
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66411 Advisory: Coder logs sensitive objects unsanitized IDs: CVE-2025-66411, GHSA-jf75-p25m-pw74 Record: https://patchnext.com/advisories/cve-2025-66411 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/coder/coder/v2 2.28.4, 2.27.7, 2.26.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/coder/coder/v2: affected < 2.26.5; >= 2.27.0, < 2.27.7; >= 2.28.0, < 2.28.4; fixed in 2.28.4, 2.27.7, 2.26.5 ## Suggested inspection (read-only) - Go github.com/coder/coder/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/coder/coder/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jf75-p25m-pw74 (GitHub-reviewed advisory GHSA-jf75-p25m-pw74 lists affected ranges: Go github.com/coder/coder/v2 >=0 =2.27.0 =2.28.0 <2.28.4) Commands are suggestions: review each one before running it.
Loading voting…