mcp-server-kubernetes has potential security issue in exec_in_pod tool
CVE-2025-66404GHSA-wvxp-jp4w-w8wg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-server-kubernetes 2.9.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 2.9.7
- Fixed in
- 2.9.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wvxp-jp4w-w8wg lists affected ranges: npm mcp-server-kubernetes >=0 <2.9.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvxp-jp4w-w8wg lists affected ranges: npm mcp-server-kubernetes >=0 <=2.9.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-66404: 1.48% estimated exploitation activity in the next 30 days; percentile 73.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A security issue exists in the execinpod tool of the mcp-server-kubernetes MCP Server. The tool accepts user-provided commands in both array and string formats. When a string format is provided, it is passed directly to shell interpretation (sh -c) without input validation, allowing shell metacharacters to be interpreted. This vulnerability can be exploited through direct command injection or indirect prompt injection attacks, where AI agents may execute commands without explicit user intent. Details The MCP Server exposes the execinpod tool to execute commands inside Kubernetes pods. The tool supports both array and string command formats. The Kubernetes Exec API (via @kubernetes/client-node) accepts commands as an array of strings, which executes commands directly without shell interpretation. However, when a string format is provided, the code automatically wraps it in shell execution (sh -c), which interprets shell metacharacters without any input validation. When string…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wvxp-jp4w-w8wg
- Revision 1 · created ·
Published from osv record GHSA-wvxp-jp4w-w8wg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66404 Advisory: mcp-server-kubernetes has potential security issue in exec_in_pod tool IDs: CVE-2025-66404, GHSA-wvxp-jp4w-w8wg Record: https://patchnext.com/advisories/cve-2025-66404 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mcp-server-kubernetes 2.9.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mcp-server-kubernetes: affected <= 2.9.7; fixed in 2.9.8 ## Suggested inspection (read-only) - `npm ls mcp-server-kubernetes --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mcp-server-kubernetes. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wvxp-jp4w-w8wg (OSV record GHSA-wvxp-jp4w-w8wg lists affected ranges: npm mcp-server-kubernetes >=0 <2.9.8 (fixed)) - Verified: https://github.com/advisories/GHSA-wvxp-jp4w-w8wg (GitHub-reviewed advisory GHSA-wvxp-jp4w-w8wg lists affected ranges: npm mcp-server-kubernetes >=0 <=2.9.7) Commands are suggestions: review each one before running it.
Loading voting…