mdast-util-to-hast has unsanitized class attribute
CVE-2025-66400GHSA-4fh9-h7wg-q85m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mdast-util-to-hast 13.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 13.0.0, < 13.2.1
- Fixed in
- 13.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4fh9-h7wg-q85m lists affected ranges: npm mdast-util-to-hast >=13.0.0 <13.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4fh9-h7wg-q85m lists affected ranges: npm mdast-util-to-hast >=13.0.0 <13.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-66400: 0.33% estimated exploitation activity in the next 30 days; percentile 25.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Multiple (unprefixed) classnames could be added in markdown source by using character references. This could make rendered user supplied markdown code elements appear like the rest of the page. The following markdown: js xss Would create <pre<code class="language-js xss"</code</pre If your page then applied .xss classes (or listeners in JS), those apply to this element. For more info see <https://github.com/ChALkeR/notes/blob/master/Improper-markup-sanitization.md#unsanitized-class-attribute Patches The bug was patched. When using regular semver, run npm install. For exact ranges, make sure to use 13.2.1. Workarounds Update. References bug introduced in https://github.com/syntax-tree/mdast-util-to-hast/commit/6fc783ae6abdeb798fd5a68e7f3f21411dde7403 bug fixed in https://github.com/syntax-tree/mdast-util-to-hast/commit/ab3a79570a1afbfa7efef5d4a0cd9b5caafbc5d7
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4fh9-h7wg-q85m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4fh9-h7wg-q85m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66400 Advisory: mdast-util-to-hast has unsanitized class attribute IDs: CVE-2025-66400, GHSA-4fh9-h7wg-q85m Record: https://patchnext.com/advisories/cve-2025-66400 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mdast-util-to-hast 13.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mdast-util-to-hast: affected >= 13.0.0, < 13.2.1; fixed in 13.2.1 ## Suggested inspection (read-only) - `npm ls mdast-util-to-hast --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mdast-util-to-hast. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4fh9-h7wg-q85m (OSV record GHSA-4fh9-h7wg-q85m lists affected ranges: npm mdast-util-to-hast >=13.0.0 <13.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-4fh9-h7wg-q85m (GitHub-reviewed advisory GHSA-4fh9-h7wg-q85m lists affected ranges: npm mdast-util-to-hast >=13.0.0 <13.2.1) Commands are suggestions: review each one before running it.
Loading voting…