Skip to content

← Actionable
Critical, CVSS 9.6amended

Signal K Server has Unauthenticated State Pollution leading to Remote Code Execution (RCE)

CVE-2025-66398GHSA-w3x5-7c4c-66p9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (signalk-server 2.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-66398: 19.85% estimated exploitation activity in the next 30 days; percentile 97.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated attacker can pollute the internal state (restoreFilePath) of the server via the /skServer/validateBackup endpoint. This allows the attacker to hijack the administrator's "Restore" functionality to overwrite critical server configuration files (e.g., security.json, package.json), leading to account takeover and Remote Code Execution (RCE). Details The vulnerability is caused by the use of a module-level global variable restoreFilePath in src/serverroutes.ts, which is shared across all requests. Vulnerable Code Analysis: 1. Global State: restoreFilePath is defined at the top level of the module. 2. Unauthenticated State Pollution: The /skServer/validateBackup endpoint updates this variable. Crucially, this endpoint lacks authentication middleware, allowing any user to access it. 3. Restore Hijacking: The /skServer/restore endpoint uses the polluted restoreFilePath to perform the restoration. Exploit Chain: 1. Pollution: Attacker uploads a malicious zip file…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w3x5-7c4c-66p9

  2. Revision 2 · amended ·

    Amended from osv record GHSA-w3x5-7c4c-66p9

  3. Revision 1 · created ·

    Published from ghsa record GHSA-w3x5-7c4c-66p9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66398

Advisory: Signal K Server has Unauthenticated State Pollution leading to Remote Code Execution (RCE)
IDs: CVE-2025-66398, GHSA-w3x5-7c4c-66p9
Record: https://patchnext.com/advisories/cve-2025-66398 (revision 3, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: signalk-server 2.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm signalk-server: affected < 2.19.0; fixed in 2.19.0

## Suggested inspection (read-only)
- `npm ls signalk-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on signalk-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w3x5-7c4c-66p9 (GitHub-reviewed advisory GHSA-w3x5-7c4c-66p9 lists affected ranges: npm signalk-server >=0 <2.19.0)
- Verified: https://osv.dev/vulnerability/GHSA-w3x5-7c4c-66p9 (OSV record GHSA-w3x5-7c4c-66p9 lists affected ranges: npm signalk-server >=0 <2.19.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…