Apache Doris MCP Server vulnerable to SQL Injection via improper query context neutralization
CVE-2025-66335GHSA-qhfq-gvvc-5q6q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (doris-mcp-server 0.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI doris-mcp-server
- Affected
- >= 0.1.0, < 0.6.1
- Fixed in
- 0.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qhfq-gvvc-5q6q lists affected ranges: PyPI doris-mcp-server >=0.1.0 <0.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qhfq-gvvc-5q6q lists affected ranges: PyPI doris-mcp-server >=0.1.0 <0.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-66335: 0.66% estimated exploitation activity in the next 30 days; percentile 51.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Doris MCP Server versions prior to 0.6.1 are affected by an improper neutralization flaw in query context handling that may allow execution of unintended SQL statements and bypass of intended query validation and access restrictions through the MCP query execution interface. Versions 0.6.1 and later are not affected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qhfq-gvvc-5q6q
- Revision 1 · created ·
Published from osv record GHSA-qhfq-gvvc-5q6q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66335 Advisory: Apache Doris MCP Server vulnerable to SQL Injection via improper query context neutralization IDs: CVE-2025-66335, GHSA-qhfq-gvvc-5q6q Record: https://patchnext.com/advisories/cve-2025-66335 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: doris-mcp-server 0.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI doris-mcp-server: affected >= 0.1.0, < 0.6.1; fixed in 0.6.1 ## Suggested inspection (read-only) - `python -m pip show doris-mcp-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on doris-mcp-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qhfq-gvvc-5q6q (OSV record GHSA-qhfq-gvvc-5q6q lists affected ranges: PyPI doris-mcp-server >=0.1.0 <0.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-qhfq-gvvc-5q6q (GitHub-reviewed advisory GHSA-qhfq-gvvc-5q6q lists affected ranges: PyPI doris-mcp-server >=0.1.0 <0.6.1) Commands are suggestions: review each one before running it.
Loading voting…