Skip to content

← Actionable
Medium, CVSS 6.2

Grav is vulnerable to Cross-Site Scripting (XSS) Reflected endpoint /admin/pages/[page], parameter data[header][content][items], located in the "Blog Config" tab

CVE-2025-66309GHSA-65mj-f7p4-wggq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 1.8.0-beta.27), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getgrav/grav

    Affected
    < 1.8.0-beta.27
    Fixed in
    1.8.0-beta.27

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-66309: 0.25% estimated exploitation activity in the next 30 days; percentile 16.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Reflected Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][content][items] parameter. --- Details Vulnerable Endpoint: GET /admin/pages/[page] Parameter: data[header][content][items] The application fails to properly validate and sanitize user input in the data[header][content][items] parameter. As a result, attackers can craft a malicious URL with an XSS payload. When this URL is accessed, the injected script is reflected back in the HTTP response and executed within the context of the victim's browser session. --- PoC Payload: "<ImG sRc=x OnErRoR=alert('XSS-PoC3') 1. Log in to the Grav Admin Panel and navigate to Pages. 2. Create a new page or edit an existing one. 3. In the Advanced Blog Config Items field (which maps to data[header][content][items]), insert the payload above. 4. Save the page. 5. The malicious payload…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-65mj-f7p4-wggq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66309

Advisory: Grav is vulnerable to Cross-Site Scripting (XSS) Reflected endpoint /admin/pages/[page], parameter data[header][content][items], located in the "Blog Config" tab
IDs: CVE-2025-66309, GHSA-65mj-f7p4-wggq
Record: https://patchnext.com/advisories/cve-2025-66309 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 1.8.0-beta.27. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getgrav/grav: affected < 1.8.0-beta.27; fixed in 1.8.0-beta.27

## Suggested inspection (read-only)
- Packagist getgrav/grav: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getgrav/grav.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-65mj-f7p4-wggq (GitHub-reviewed advisory GHSA-65mj-f7p4-wggq lists affected ranges: Packagist getgrav/grav >=0 <1.8.0-beta.27)

Commands are suggestions: review each one before running it.

Loading voting…