Grav vulnerable to Denial of Service via Improper Input Handling in 'Supported' Parameter
CVE-2025-66305GHSA-m8vh-v6r6-w7p6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 1.8.0-beta.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- < 1.8.0-beta.27
- Fixed in
- 1.8.0-beta.27
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m8vh-v6r6-w7p6 lists affected ranges: Packagist getgrav/grav >=0 <1.8.0-beta.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H · score source
- EPSS
- CVE-2025-66305: 0.41% estimated exploitation activity in the next 30 days; percentile 35.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Endpoint: admin/config/system Submenu: Languages Parameter: Supported Application: Grav v 1.7.48 --- Summary A Denial of Service (DoS) vulnerability was identified in the "Languages" submenu of the Grav admin configuration panel (/admin/config/system). Specifically, the Supported parameter fails to properly validate user input. If a malformed value is inserted—such as a single forward slash (/) or an XSS test string—it causes a fatal regular expression parsing error on the server. This leads to application-wide failure due to the use of the pregmatch() function with an improperly constructed regular expression, resulting in the following error: pregmatch(): Unknown modifier 'o' File: /system/src/Grav/Common/Language/Language.php line 244 Once triggered, the site becomes completely unavailable to all users. --- Details - Vulnerable Endpoint: POST /admin/config/system - Submenu: Languages - Parameter: Supported The application dynamically constructs a regular expression using the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m8vh-v6r6-w7p6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66305 Advisory: Grav vulnerable to Denial of Service via Improper Input Handling in 'Supported' Parameter IDs: CVE-2025-66305, GHSA-m8vh-v6r6-w7p6 Record: https://patchnext.com/advisories/cve-2025-66305 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 1.8.0-beta.27. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected < 1.8.0-beta.27; fixed in 1.8.0-beta.27 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m8vh-v6r6-w7p6 (GitHub-reviewed advisory GHSA-m8vh-v6r6-w7p6 lists affected ranges: Packagist getgrav/grav >=0 <1.8.0-beta.27) Commands are suggestions: review each one before running it.
Loading voting…