Skip to content

← Actionable
High, CVSS 8.5

Grav is vulnerable to Arbitrary File Read

CVE-2025-66300GHSA-p4ww-mcp9-j6f2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 1.8.0-beta.27), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getgrav/grav

    Affected
    < 1.8.0-beta.27
    Fixed in
    1.8.0-beta.27

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:L
EPSS
  • CVE-2025-66300: 0.49% estimated exploitation activity in the next 30 days; percentile 41.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary - A low privilege user account with page editing privilege can read any server files using "Frontmatter" form. - This includes Grav user account files - /grav/user/accounts/.yaml. This file stores hashed user password, 2FA secret, and the password reset token. - This can allow an adversary to compromise any registered account by resetting a password for a user to get access to the password reset token from the file or by cracking the hashed password. Details The vulnerability can be found in /user/plugins/form/templates/forms/fields/display/display.html.twig PoC 1. This PoC was conducted on Grav CMS version 1.7.46 and Admin Plugin version 1.10.46 2. go to “http://grav.local/admin/pages” then create new page with “Page Template” option set to “Form”. 3. Then go to “Expert” and on Frontmatter input box used to following form template. 4. Save page and go the preview or published page you will see the content of “/etc/passwd” file on the server. Impact This can allow a low…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p4ww-mcp9-j6f2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66300

Advisory: Grav is vulnerable to Arbitrary File Read
IDs: CVE-2025-66300, GHSA-p4ww-mcp9-j6f2
Record: https://patchnext.com/advisories/cve-2025-66300 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 1.8.0-beta.27. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getgrav/grav: affected < 1.8.0-beta.27; fixed in 1.8.0-beta.27

## Suggested inspection (read-only)
- Packagist getgrav/grav: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getgrav/grav.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p4ww-mcp9-j6f2 (GitHub-reviewed advisory GHSA-p4ww-mcp9-j6f2 lists affected ranges: Packagist getgrav/grav >=0 <1.8.0-beta.27)

Commands are suggestions: review each one before running it.

Loading voting…