Grav is Vulnerable to Security Sandbox Bypass with SSTI (Server Side Template Injection)
CVE-2025-66299GHSA-gjc5-8cfh-653x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getgrav/grav 1.8.0-beta.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- < 1.8.0-beta.27
- Fixed in
- 1.8.0-beta.27
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gjc5-8cfh-653x lists affected ranges: Packagist getgrav/grav >=0 <1.8.0-beta.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-66299: 0.65% estimated exploitation activity in the next 30 days; percentile 51.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Grav CMS is vulnerable to a Server-Side Template Injection (SSTI) that allows any authenticated user with editor permissions to execute arbitrary code on the remote server, bypassing the existing security sandbox. Details Grav CMS uses a custom sandbox to protect the powerful Twig methods such as registerUndefinedFilterCallback(). These methods are designed to prevent SSTI attacks by denying the execution of dangerous PHP functions (e.g., exec(), passthru(), system(), etc.) within Twig template directives. The current defense mechanism relies on a blacklist of prohibited functions (PHP, Twig), checked through the isDangerousFunction() method in the file system/src/Grav/Common/Twig.php: In this code, the isDangerousFunction() check is bypassed if the filter defined in the $name variable is considered safe. Only an administrator can mark a function as safe by adding it to the system.twig.safefilters configuration properties (whitelists that are empty by default) in the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gjc5-8cfh-653x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66299 Advisory: Grav is Vulnerable to Security Sandbox Bypass with SSTI (Server Side Template Injection) IDs: CVE-2025-66299, GHSA-gjc5-8cfh-653x Record: https://patchnext.com/advisories/cve-2025-66299 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getgrav/grav 1.8.0-beta.27. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected < 1.8.0-beta.27; fixed in 1.8.0-beta.27 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gjc5-8cfh-653x (GitHub-reviewed advisory GHSA-gjc5-8cfh-653x lists affected ranges: Packagist getgrav/grav >=0 <1.8.0-beta.27) Commands are suggestions: review each one before running it.
Loading voting…