Astro has an Authentication Bypass via Double URL Encoding, a bypass for CVE-2025-64765
CVE-2025-66202GHSA-whqg-ppgf-wp8c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (astro 5.15.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm astro
- Affected
- < 5.15.8
- Fixed in
- 5.15.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-whqg-ppgf-wp8c lists affected ranges: npm astro >=0 <5.15.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-whqg-ppgf-wp8c lists affected ranges: npm astro >=0 <5.15.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-66202: 0.31% estimated exploitation activity in the next 30 days; percentile 24.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Authentication Bypass via Double URL Encoding in Astro Bypass for CVE-2025-64765 / GHSA-ggxq-hp9w-j794 --- Summary A double URL encoding bypass allows any unauthenticated attacker to bypass path-based authentication checks in Astro middleware, granting unauthorized access to protected routes. While the original CVE-2025-64765 (single URL encoding) was fixed in v5.15.8, the fix is insufficient as it only decodes once. By using double-encoded URLs like /%2561dmin instead of /%61dmin, attackers can still bypass authentication and access protected resources such as /admin, /api/internal, or any route protected by middleware pathname checks. Fix A more secure fix is just decoding once, then if the request has a %xx format, return a 400 error by using something like :
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-whqg-ppgf-wp8c
- Revision 1 · created ·
Published from osv record GHSA-whqg-ppgf-wp8c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66202 Advisory: Astro has an Authentication Bypass via Double URL Encoding, a bypass for CVE-2025-64765 IDs: CVE-2025-66202, GHSA-whqg-ppgf-wp8c Record: https://patchnext.com/advisories/cve-2025-66202 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: astro 5.15.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm astro: affected < 5.15.8; fixed in 5.15.8 ## Suggested inspection (read-only) - `npm ls astro --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on astro. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-whqg-ppgf-wp8c (OSV record GHSA-whqg-ppgf-wp8c lists affected ranges: npm astro >=0 <5.15.8 (fixed)) - Verified: https://github.com/advisories/GHSA-whqg-ppgf-wp8c (GitHub-reviewed advisory GHSA-whqg-ppgf-wp8c lists affected ranges: npm astro >=0 <5.15.8) Commands are suggestions: review each one before running it.
Loading voting…