Skip to content

← Actionable
Low, CVSS 3.6amended

Spotipy has a XSS vulnerability in its OAuth callback server

CVE-2025-66040GHSA-r77h-rpp9-w2xm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (spotipy 2.25.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI spotipy

    Affected
    < 2.25.2
    Fixed in
    2.25.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.6 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-66040: 0.17% estimated exploitation activity in the next 30 days; percentile 5.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary XSS vulnerability in OAuth callback server allows JavaScript injection through unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. Details Vulnerable Code: spotipy/oauth2.py lines 1238-1274 (RequestHandler.doGET) The Problem: During OAuth flow, spotipy starts a local HTTP server to receive callbacks. The server reflects the error URL parameter directly into HTML without sanitization. Vulnerable code at line 1255: Then embedded in HTML at line 1265: The error parameter comes from URL parsing (lines 388-393) without HTML escaping, allowing script injection. Attack Flow: 1. User starts OAuth authentication → local server runs on http://127.0.0.1:8080 2. Attacker crafts malicious URL: http://127.0.0.1:8080/?error=<scriptalert(1)</script&state=x 3. User visits URL → JavaScript executes in localhost origin PoC Simple Python Test: Run it: Output shows: The Proof: - Expected (safe):…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r77h-rpp9-w2xm

  2. Revision 1 · created ·

    Published from osv record GHSA-r77h-rpp9-w2xm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66040

Advisory: Spotipy has a XSS vulnerability in its OAuth callback server
IDs: CVE-2025-66040, GHSA-r77h-rpp9-w2xm
Record: https://patchnext.com/advisories/cve-2025-66040 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: spotipy 2.25.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI spotipy: affected < 2.25.2; fixed in 2.25.2

## Suggested inspection (read-only)
- `python -m pip show spotipy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on spotipy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r77h-rpp9-w2xm (OSV record GHSA-r77h-rpp9-w2xm lists affected ranges: PyPI spotipy >=0 <2.25.2 (fixed))
- Verified: https://github.com/advisories/GHSA-r77h-rpp9-w2xm (GitHub-reviewed advisory GHSA-r77h-rpp9-w2xm lists affected ranges: PyPI spotipy >=0 <2.25.2)

Commands are suggestions: review each one before running it.

Loading voting…