Skip to content

← Actionable
High, CVSS 7.7amended

Angular is Vulnerable to XSRF Token Leakage via Protocol-Relative URLs in Angular HTTP Client

CVE-2025-66035GHSA-58c5-g7wp-6w37

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@angular/common 21.0.1, 20.3.14, 19.2.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @angular/common

    Affected
    >= 21.0.0-next.0, < 21.0.1>= 20.0.0-next.0, < 20.3.14< 19.2.16
    Fixed in
    21.0.1, 20.3.14, 19.2.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2025-66035: 0.72% estimated exploitation activity in the next 30 days; percentile 53.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The vulnerability is a Credential Leak by App Logic that leads to the unauthorized disclosure of the Cross-Site Request Forgery (XSRF) token to an attacker-controlled domain. Angular's HttpClient has a built-in XSRF protection mechanism that works by checking if a request URL starts with a protocol (http:// or https://) to determine if it is cross-origin. If the URL starts with protocol-relative URL (//), it is incorrectly treated as a same-origin request, and the XSRF token is automatically added to the X-XSRF-TOKEN header. Impact The token leakage completely bypasses Angular's built-in CSRF protection, allowing an attacker to capture the user's valid XSRF token. Once the token is obtained, the attacker can perform arbitrary Cross-Site Request Forgery (CSRF) attacks against the victim user's session. Attack Preconditions 1. The victim's Angular application must have XSRF protection enabled. 2. The attacker must be able to make the application send a state-changing HTTP request…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-58c5-g7wp-6w37

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-58c5-g7wp-6w37

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66035

Advisory: Angular is Vulnerable to XSRF Token Leakage via Protocol-Relative URLs in Angular HTTP Client
IDs: CVE-2025-66035, GHSA-58c5-g7wp-6w37
Record: https://patchnext.com/advisories/cve-2025-66035 (revision 3, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @angular/common 21.0.1, 20.3.14, 19.2.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @angular/common: affected >= 21.0.0-next.0, < 21.0.1; >= 20.0.0-next.0, < 20.3.14; < 19.2.16; fixed in 21.0.1, 20.3.14, 19.2.16

## Suggested inspection (read-only)
- `npm ls @angular/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @angular/common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-58c5-g7wp-6w37 (OSV record GHSA-58c5-g7wp-6w37 lists affected ranges: npm @angular/common >=21.0.0-next.0 =20.0.0-next.0 =0 <19.2.16 (fixed))
- Verified: https://github.com/advisories/GHSA-58c5-g7wp-6w37 (GitHub-reviewed advisory GHSA-58c5-g7wp-6w37 lists affected ranges: npm @angular/common >=21.0.0-next.0 =20.0.0-next.0 =0 <19.2.16)

Commands are suggestions: review each one before running it.

Loading voting…