Skip to content

← Actionable
High, CVSS 8.6

XWiki Blog Application home page vulnerable to Stored XSS via Post Title

CVE-2025-66024GHSA-h2xq-h7f9-vh6c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.contrib.blog:application-blog-ui 9.15.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-66024: 0.44% estimated exploitation activity in the next 30 days; percentile 38.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Blog Application is vulnerable to Stored Cross-Site Scripting (XSS) via the Blog Post Title. The vulnerability arises because the post title is injected directly into the HTML <title tag without proper escaping. An attacker with permissions to create or edit blog posts can inject malicious JavaScript into the title field. This script will execute in the browser of any user (including administrators) who views the blog post. This leads to potential session hijacking or privilege escalation. To reproduce: Log in as a user with rights to create blog posts. Create a new blog post. In the Title field, insert the following payload designed to break out of the title tag: Save (Publish) the post. View the post in the blog home page Patches The vulnerability has been patched in the blog application version 9.15.7 by adding missing escaping. Workarounds We're not aware of any workarounds. References https://jira.xwiki.org/browse/BLOG-245…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h2xq-h7f9-vh6c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-66024

Advisory: XWiki Blog Application home page vulnerable to Stored XSS via Post Title
IDs: CVE-2025-66024, GHSA-h2xq-h7f9-vh6c
Record: https://patchnext.com/advisories/cve-2025-66024 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.contrib.blog:application-blog-ui 9.15.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.contrib.blog:application-blog-ui: affected >= 9.15, < 9.15.7; fixed in 9.15.7

## Suggested inspection (read-only)
- Maven org.xwiki.contrib.blog:application-blog-ui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.contrib.blog:application-blog-ui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h2xq-h7f9-vh6c (GitHub-reviewed advisory GHSA-h2xq-h7f9-vh6c lists affected ranges: Maven org.xwiki.contrib.blog:application-blog-ui >=9.15 <9.15.7)

Commands are suggestions: review each one before running it.

Loading voting…