Valibot has a ReDoS vulnerability in EMOJI_REGEX
CVE-2025-66020GHSA-vqpr-j7v3-hqw9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (valibot 1.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm valibot
- Affected
- >= 0.31.0, < 1.2.0
- Fixed in
- 1.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vqpr-j7v3-hqw9 lists affected ranges: npm valibot >=0.31.0 <1.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vqpr-j7v3-hqw9 lists affected ranges: npm valibot >=0.31.0 <1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-66020: 0.36% estimated exploitation activity in the next 30 days; percentile 29.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The EMOJIREGEX used in the emoji action is vulnerable to a Regular Expression Denial of Service (ReDoS) attack. A short, maliciously crafted string (e.g., <100 characters) can cause the regex engine to consume excessive CPU time (minutes), leading to a Denial of Service (DoS) for the application. Details The ReDoS vulnerability stems from "catastrophic backtracking" in the EMOJIREGEX. This is caused by ambiguity in the regex pattern due to overlapping character classes. Specifically, the class \p{EmojiPresentation} overlaps with more specific classes used in the same alternation, such as [\u{1F1E6}-\u{1F1FF}] (regional indicator symbols used for flags) and \p{EmojiModifierBase}. When the regex engine attempts to match a string that almost matches but ultimately fails (like the one in the PoC), this ambiguity forces it to explore an exponential number of possible paths. The matching time increases exponentially with the length of the crafted input, rather than linearly. PoC…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vqpr-j7v3-hqw9
- Revision 1 · created ·
Published from osv record GHSA-vqpr-j7v3-hqw9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-66020 Advisory: Valibot has a ReDoS vulnerability in `EMOJI_REGEX` IDs: CVE-2025-66020, GHSA-vqpr-j7v3-hqw9 Record: https://patchnext.com/advisories/cve-2025-66020 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: valibot 1.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm valibot: affected >= 0.31.0, < 1.2.0; fixed in 1.2.0 ## Suggested inspection (read-only) - `npm ls valibot --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on valibot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vqpr-j7v3-hqw9 (OSV record GHSA-vqpr-j7v3-hqw9 lists affected ranges: npm valibot >=0.31.0 <1.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vqpr-j7v3-hqw9 (GitHub-reviewed advisory GHSA-vqpr-j7v3-hqw9 lists affected ranges: npm valibot >=0.31.0 <1.2.0) Commands are suggestions: review each one before running it.
Loading voting…