Skip to content

← Actionable
High, CVSS 8.2

Grype has a credential disclosure vulnerability in its JSON output

CVE-2025-65965GHSA-6gxw-85q2-q646

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/anchore/grype 0.104.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2025-65965: 0.16% estimated exploitation activity in the next 30 days; percentile 5.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A credential disclosure vulnerability was found in Grype, affecting versions v0.68.0 through v0.104.0. If registry credentials are defined and the output of grype is written using the --file or --output json=<file option, the registry credentials will be included unsanitized in the output file. Impact In Grype versions v0.68.0 through v0.104.0, when registry authentication is configured, those credentials can be incorrectly included in the output of a Grype scan (regardless of whether those credentials are actively being used for the current scan). Users that do not have registry authentication configured are not affected by this issue. Registry credentials can be set via the Grype configuration file (e.g. registry.auth[].username, registry.auth[].password, registry.auth[].token) or environment variables (e.g., GRYPEREGISTRYAUTHUSERNAME, GRYPEREGISTRYAUTHPASSWORD, GRYPEREGISTRYAUTHTOKEN). In order for the authentication details to be improperly included, the Grype file output format…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6gxw-85q2-q646

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-65965

Advisory: Grype has a credential disclosure vulnerability in its JSON output
IDs: CVE-2025-65965, GHSA-6gxw-85q2-q646
Record: https://patchnext.com/advisories/cve-2025-65965 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/anchore/grype 0.104.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/anchore/grype: affected >= 0.68.0, < 0.104.1; fixed in 0.104.1

## Suggested inspection (read-only)
- Go github.com/anchore/grype: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/anchore/grype.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6gxw-85q2-q646 (GitHub-reviewed advisory GHSA-6gxw-85q2-q646 lists affected ranges: Go github.com/anchore/grype >=0.68.0 <0.104.1)

Commands are suggestions: review each one before running it.

Loading voting…