Skip to content

← Actionable
Critical, CVSS 9.4amended

n8n vulnerable to Remote Code Execution via Git Node Custom Pre-Commit Hook

CVE-2025-65964GHSA-wpqc-h9wp-chmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.119.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 0.123.1, < 1.119.2
    Fixed in
    1.119.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-65964: 0.66% estimated exploitation activity in the next 30 days; percentile 51.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The n8n Git node allows workflows to set arbitrary Git configuration values through the Add Config operation. When an attacker-controlled workflow sets core.hooksPath to a directory within the cloned repository containing a Git hook such as pre-commit, Git executes that hook during subsequent Git operations. Because Git hooks run as local system commands, this behavior can lead to arbitrary command execution on the underlying n8n host. Successful exploitation requires the ability to create or modify an n8n workflow that uses the Git node. Affected versions: ≥ 0.123.1 and < 1.119.2 Patches This issue has been patched in n8n version 1.119.2. All users running affected versions should upgrade to 1.119.2 or later. Workarounds If upgrading is not immediately possible, the following mitigations can reduce exposure: - Exclude the Git node (Docs). - Avoid cloning or interacting with untrusted repositories using the Git Node.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-wpqc-h9wp-chmq

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-wpqc-h9wp-chmq

  4. Revision 1 · created ·

    Published from ghsa record GHSA-wpqc-h9wp-chmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-65964

Advisory: n8n vulnerable to Remote Code Execution via Git Node Custom Pre-Commit Hook
IDs: CVE-2025-65964, GHSA-wpqc-h9wp-chmq
Record: https://patchnext.com/advisories/cve-2025-65964 (revision 4, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 1.119.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 0.123.1, < 1.119.2; fixed in 1.119.2

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wpqc-h9wp-chmq (GitHub-reviewed advisory GHSA-wpqc-h9wp-chmq lists affected ranges: npm n8n >=0.123.1 <1.119.2)
- Verified: https://osv.dev/vulnerability/GHSA-wpqc-h9wp-chmq (OSV record GHSA-wpqc-h9wp-chmq lists affected ranges: npm n8n >=0.123.1 <1.119.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…