Skip to content

← Actionable
High, CVSS 8.5amended

Open WebUI vulnerable to Server-Side Request Forgery (SSRF) via Arbitrary URL Processing in /api/v1/retrieval/process/web

CVE-2025-65958GHSA-c6xv-rcvw-v685

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.6.37), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2025-65958: 4.43% estimated exploitation activity in the next 30 days; percentile 91.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Server-Side Request Forgery (SSRF) vulnerability in Open WebUI allows any authenticated user to force the server to make HTTP requests to arbitrary URLs. This can be exploited to access cloud metadata endpoints (AWS/GCP/Azure), scan internal networks, access internal services behind firewalls, and exfiltrate sensitive information. No special permissions beyond basic authentication are required. Details The vulnerability exists in the /api/v1/retrieval/process/web endpoint located in backend/openwebui/routers/retrieval.py at lines 1758-1767. Vulnerable code: @router.post("/process/web") def processweb( request: Request, formdata: ProcessUrlForm, user=Depends(getverifieduser) ): try: collectionname = formdata.collectionname if not collectionname: collectionname = calculatesha256string(formdata.url)[:63] content, docs = getcontentfromurl(request, formdata.url)

← SSRF vulnerability The formdata.url parameter is passed directly to getcontentfromurl() without any validation.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c6xv-rcvw-v685

  2. Revision 1 · created ·

    Published from osv record GHSA-c6xv-rcvw-v685

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-65958

Advisory: Open WebUI vulnerable to Server-Side Request Forgery (SSRF) via Arbitrary URL Processing in /api/v1/retrieval/process/web
IDs: CVE-2025-65958, GHSA-c6xv-rcvw-v685
Record: https://patchnext.com/advisories/cve-2025-65958 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.6.37. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.6.36; fixed in 0.6.37

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c6xv-rcvw-v685 (OSV record GHSA-c6xv-rcvw-v685 lists affected ranges: PyPI open-webui >=0 <0.6.37 (fixed))
- Verified: https://github.com/advisories/GHSA-c6xv-rcvw-v685 (GitHub-reviewed advisory GHSA-c6xv-rcvw-v685 lists affected ranges: PyPI open-webui >=0 <=0.6.36)

Commands are suggestions: review each one before running it.

Loading voting…