Logrus is vulnerable to DoS when using Entry.Writer()
CVE-2025-65637GHSA-4f99-4q7p-p3gh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/sirupsen/logrus 1.9.3, 1.9.1, 1.8.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.8.3>= 1.9.0, <= 1.9.0>= 1.9.2, <= 1.9.2
- Fixed in
- 1.8.3, 1.9.3, 1.9.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4f99-4q7p-p3gh lists affected ranges: Go github.com/sirupsen/logrus >=0 =1.9.0 =1.9.2 <=1.9.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-65637: 0.63% estimated exploitation activity in the next 30 days; percentile 50.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A denial-of-service vulnerability exists in github.com/sirupsen/logrus when using Entry.Writer() to log a single-line payload larger than 64KB without newline characters. Due to limitations in the internal bufio.Scanner, the read fails with "token too long" and the writer pipe is closed, leaving Writer() unusable and causing application unavailability (DoS). This affects versions < 1.8.3, 1.9.0, and 1.9.2. The issue is fixed in 1.8.3, 1.9.1, and 1.9.3+, where the input is chunked and the writer continues to function even if an error is logged.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4f99-4q7p-p3gh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-65637 Advisory: Logrus is vulnerable to DoS when using Entry.Writer() IDs: CVE-2025-65637, GHSA-4f99-4q7p-p3gh Record: https://patchnext.com/advisories/cve-2025-65637 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/sirupsen/logrus 1.9.3, 1.9.1, 1.8.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/sirupsen/logrus: affected < 1.8.3; >= 1.9.0, <= 1.9.0; >= 1.9.2, <= 1.9.2; fixed in 1.8.3, 1.9.3, 1.9.1 ## Suggested inspection (read-only) - Go github.com/sirupsen/logrus: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/sirupsen/logrus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4f99-4q7p-p3gh (GitHub-reviewed advisory GHSA-4f99-4q7p-p3gh lists affected ranges: Go github.com/sirupsen/logrus >=0 =1.9.0 =1.9.2 <=1.9.2) Commands are suggestions: review each one before running it.
Loading voting…