PYSEC-2025-89
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cashu 0.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI cashu
- Affected
- < 0.18.0
- Fixed in
- 0.18.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2025-89 lists affected ranges: PyPI cashu >=0 <0.18.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-65548: 0.42% estimated exploitation activity in the next 30 days; percentile 35.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
NUT-14 allows cashu tokens to be created with a preimage hash. However, nutshell (cashubtc/nuts) before 0.18.0 do not validate the size of preimage when the token is spent. The preimage is stored by the mint and attacker can exploit this vulnerability to fill the mint's db nd disk with arbitrary data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record PYSEC-2025-89
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-65548 Advisory: PYSEC-2025-89 IDs: CVE-2025-65548 Record: https://patchnext.com/advisories/cve-2025-65548 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cashu 0.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI cashu: affected < 0.18.0; fixed in 0.18.0 ## Suggested inspection (read-only) - `python -m pip show cashu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cashu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2025-89 (OSV record PYSEC-2025-89 lists affected ranges: PyPI cashu >=0 <0.18.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…