Skip to content

← Actionable
Critical, CVSS 9.1amended

pbkdf2 silently disregards Uint8Array input, returning static keys

CVE-2025-6547GHSA-v62p-rq8g-8h59

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pbkdf2 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pbkdf2

    Affected
    >= 1.0.0, <= 3.1.2
    Fixed in
    3.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-6547: 0.46% estimated exploitation activity in the next 30 days; percentile 40.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary On historic but declared as supported Node.js versions (0.12-2.x), pbkdf2 silently disregards Uint8Array input This only affects Node.js <3.0.0, but pbkdf2 claims to: Support Node.js = 0.12 (and there seems to be ongoing effort in this repo to maintain that) Support Uint8Array input (input is typechecked against Uint8Array, and the error message includes e.g. "Password must be a string, a Buffer, a typed array or a DataView" Details The error is in toBuffer method This vulnerability somehow even made it to tests: https://github.com/browserify/pbkdf2/commit/eb9f97a66ed83836bebc4ff563a1588248708501 There, resultsOld (where mismatch results) are just invalid output generated from empty password/salt instead of the supplied one PoC On Node.js/io.js < 3.0.0 Impact Static hashes being outputted and used as keys/passwords can completely undermine security That said, no one should be using those Node.js versions anywhere now, so I would recommend to just drop them This lib should not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v62p-rq8g-8h59

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-v62p-rq8g-8h59

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-6547

Advisory: pbkdf2 silently disregards Uint8Array input, returning static keys
IDs: CVE-2025-6547, GHSA-v62p-rq8g-8h59
Record: https://patchnext.com/advisories/cve-2025-6547 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pbkdf2 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pbkdf2: affected >= 1.0.0, <= 3.1.2; fixed in 3.1.3

## Suggested inspection (read-only)
- `npm ls pbkdf2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pbkdf2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v62p-rq8g-8h59 (OSV record GHSA-v62p-rq8g-8h59 lists affected ranges: npm pbkdf2 >=1.0.0 <3.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-v62p-rq8g-8h59 (GitHub-reviewed advisory GHSA-v62p-rq8g-8h59 lists affected ranges: npm pbkdf2 >=1.0.0 <=3.1.2)

Commands are suggestions: review each one before running it.

Loading voting…