Skip to content

← Actionable
Critical, CVSS 9.1amended

pbkdf2 returns predictable uninitialized/zero-filled memory for non-normalized or unimplemented algos

CVE-2025-6545GHSA-h7cp-r72f-jxh6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pbkdf2 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pbkdf2

    Affected
    >= 3.0.10, <= 3.1.2
    Fixed in
    3.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-6545: 0.45% estimated exploitation activity in the next 30 days; percentile 38.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary This affects both: 1. Unsupported algos (e.g. sha3-256 / sha3-512 / sha512-256) 2. Supported but non-normalized algos (e.g. Sha256 / Sha512 / SHA1 / sha-1 / sha-256 / sha-512) All of those work correctly in Node.js, but this polyfill silently returns highly predictable ouput Under Node.js (only with pbkdf2/browser import, unlikely) / Bun (pbkdf2 top-level import is affected), the memory is not zero-filled but is uninitialized, as Buffer.allocUnsafe is used Under browsers, it just returns zero-filled buffers (Which is also critical, those are completely unacceptable as kdf output and ruin security) Were you affected? The full list of arguments that were not affected were literal: 'md5' 'sha1' 'sha224' 'sha256' 'sha384' 'sha512' 'rmd160' 'ripemd160' Any other arguments, e.g. representation variations of the above ones like 'SHA-1'/'sha-256'/'SHA512' or different algos like 'sha3-512'/'blake2b512', while supported on Node.js crypto module, returned predictable output on pbkdf2…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-h7cp-r72f-jxh6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-h7cp-r72f-jxh6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-6545

Advisory: pbkdf2 returns predictable uninitialized/zero-filled memory for non-normalized or unimplemented algos
IDs: CVE-2025-6545, GHSA-h7cp-r72f-jxh6
Record: https://patchnext.com/advisories/cve-2025-6545 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pbkdf2 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pbkdf2: affected >= 3.0.10, <= 3.1.2; fixed in 3.1.3

## Suggested inspection (read-only)
- `npm ls pbkdf2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pbkdf2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h7cp-r72f-jxh6 (OSV record GHSA-h7cp-r72f-jxh6 lists affected ranges: npm pbkdf2 >=3.0.10 <3.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-h7cp-r72f-jxh6 (GitHub-reviewed advisory GHSA-h7cp-r72f-jxh6 lists affected ranges: npm pbkdf2 >=3.0.10 <=3.1.2)

Commands are suggestions: review each one before running it.

Loading voting…