SpiceDB: LookupResources with Multiple Entrypoints across Different Definitions Can Return Incomplete Results
CVE-2025-65111GHSA-9m7r-g8hg-x3vr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/authzed/spicedb 1.47.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.47.1
- Fixed in
- 1.47.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9m7r-g8hg-x3vr lists affected ranges: Go github.com/authzed/spicedb >=0 <1.47.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-65111: 0.23% estimated exploitation activity in the next 30 days; percentile 14.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If your schema includes the following characteristics: 1. You have a permission defined in terms of a union (+) 1. That union references the same relation on both sides, but one side arrows to a different permission Then you might have missing LookupResources results when checking the permission. This only affects LookupResources; other APIs calculate permissionship correctly. A small concrete example: A CheckPermission on dothething will return the correct permissionship, but a LookupResources on dothething may miss resources. A Comprehensive Example If you have a schema with a structure like this: And these relationships: And you call LookupResources with: You would expect to receive system:somesystem in the results, but you do not. Note that this only applies to LookupResources; if you CheckPermission for that resource specifically, it will return HasPermission. Patches The issue is fixed in v1.47.1. Upgrading to this version will remediate this issue. Workarounds N/A…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9m7r-g8hg-x3vr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-65111 Advisory: SpiceDB: LookupResources with Multiple Entrypoints across Different Definitions Can Return Incomplete Results IDs: CVE-2025-65111, GHSA-9m7r-g8hg-x3vr Record: https://patchnext.com/advisories/cve-2025-65111 (revision 1, source checked 26 Oct 2026, 15:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/authzed/spicedb 1.47.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/authzed/spicedb: affected < 1.47.1; fixed in 1.47.1 ## Suggested inspection (read-only) - Go github.com/authzed/spicedb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/authzed/spicedb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9m7r-g8hg-x3vr (GitHub-reviewed advisory GHSA-9m7r-g8hg-x3vr lists affected ranges: Go github.com/authzed/spicedb >=0 <1.47.1) Commands are suggestions: review each one before running it.
Loading voting…