Skip to content

← Actionable
High, CVSS 8.1amended

Vega XSS via expression abusing vlSelectionTuples function array map calls in environments with satisfactory function gadgets in the global scope

CVE-2025-65110GHSA-829q-m3qg-ph8r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vega-selections 6.1.2, 5.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-65110: 0.50% estimated exploitation activity in the next 30 days; percentile 43.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Applications meeting these two conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. 1. Use vega in an application that attaches both vega library and a vega.View instance similar to the Vega Editor to the global window, or has any other satisfactory function gadgets in the global scope 2. Allow user-defined Vega JSON definitions (vs JSON that was is only provided through source code) Patches - With Vega v6, use vega-selections@6.1.2 (requires ESM) - With Vega v5, use vega-selections@5.6.3 (No ESM needed) Workarounds - Do not attach vega or vega.View instances to global variables or the window as the editor used to do here . This is a development-only debugging practice that should not be used in any situation where Vega/Vega-lite definitions can come from untrusted parties. POC Summary Vega offers the evaluation of expressions in a secure context. Arbitrary function call is prohibited. When an event is exposed to an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-829q-m3qg-ph8r

  2. Revision 1 · created ·

    Published from osv record GHSA-829q-m3qg-ph8r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-65110

Advisory: Vega XSS via expression abusing vlSelectionTuples function array map calls in environments with satisfactory function gadgets in the global scope
IDs: CVE-2025-65110, GHSA-829q-m3qg-ph8r
Record: https://patchnext.com/advisories/cve-2025-65110 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vega-selections 6.1.2, 5.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vega-selections: affected < 5.6.3; >= 6.0.0, < 6.1.2; fixed in 5.6.3, 6.1.2

## Suggested inspection (read-only)
- `npm ls vega-selections --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vega-selections.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-829q-m3qg-ph8r (OSV record GHSA-829q-m3qg-ph8r lists affected ranges: npm vega-selections >=0 =6.0.0 <6.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-829q-m3qg-ph8r (GitHub-reviewed advisory GHSA-829q-m3qg-ph8r lists affected ranges: npm vega-selections >=0 =6.0.0 <6.1.2)

Commands are suggestions: review each one before running it.

Loading voting…