Skip to content

← Actionable
High, CVSS 8.3amended

LangChain Vulnerable to Template Injection via Attribute Access in Prompt Templates

CVE-2025-65106GHSA-6qv9-48xg-fc7f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain-core 1.0.7, 0.3.80), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langchain-core

    Affected
    >= 1.0.0, <= 1.0.6<= 0.3.79
    Fixed in
    0.3.80, 1.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-65106: 0.52% estimated exploitation activity in the next 30 days; percentile 44.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Context A template injection vulnerability exists in LangChain's prompt template system that allows attackers to access Python object internals through template syntax. This vulnerability affects applications that accept untrusted template strings (not just template variables) in ChatPromptTemplate and related prompt template classes. Templates allow attribute access (.) and indexing ([]) but not method invocation (()). The combination of attribute access and indexing may enable exploitation depending on which objects are passed to templates. When template variables are simple strings (the common case), the impact is limited. However, when using MessagesPlaceholder with chat message objects, attackers can traverse through object attributes and dictionary lookups (e.g., globals) to reach sensitive data such as environment variables. The vulnerability specifically requires that applications accept template strings (the structure) from untrusted sources, not just template variables (the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6qv9-48xg-fc7f

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6qv9-48xg-fc7f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-65106

Advisory: LangChain Vulnerable to Template Injection via Attribute Access in Prompt Templates
IDs: CVE-2025-65106, GHSA-6qv9-48xg-fc7f
Record: https://patchnext.com/advisories/cve-2025-65106 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langchain-core 1.0.7, 0.3.80. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langchain-core: affected >= 1.0.0, <= 1.0.6; <= 0.3.79; fixed in 0.3.80, 1.0.7

## Suggested inspection (read-only)
- `python -m pip show langchain-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langchain-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6qv9-48xg-fc7f (OSV record GHSA-6qv9-48xg-fc7f lists affected ranges: PyPI langchain-core >=1.0.0 =0 <0.3.80 (fixed))
- Verified: https://github.com/advisories/GHSA-6qv9-48xg-fc7f (GitHub-reviewed advisory GHSA-6qv9-48xg-fc7f lists affected ranges: PyPI langchain-core >=1.0.0 =0 <=0.3.79)

Commands are suggestions: review each one before running it.

Loading voting…