Apptainer ineffectively applies selinux and apparmor --security options
CVE-2025-65105GHSA-j3rw-fx6g-q46j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/apptainer/apptainer 1.4.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/apptainer/apptainer
- Affected
- < 1.4.5
- Fixed in
- 1.4.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3rw-fx6g-q46j lists affected ranges: Go github.com/apptainer/apptainer >=0 <1.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.5 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2025-65105: 0.25% estimated exploitation activity in the next 30 days; percentile 16.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:<profile and --security=selinux:<label which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. In addition, a bug in the detection of selinux support in Apptainer's suid mode means that --security selinux:<label flags may not be applied, even in the absence of an attack. In that case a warning message is emitted indicating that selinux is unavailable, but the warning may be may be overlooked, mis-interpreted,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j3rw-fx6g-q46j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-65105 Advisory: Apptainer ineffectively applies selinux and apparmor --security options IDs: CVE-2025-65105, GHSA-j3rw-fx6g-q46j Record: https://patchnext.com/advisories/cve-2025-65105 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/apptainer/apptainer 1.4.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/apptainer/apptainer: affected < 1.4.5; fixed in 1.4.5 ## Suggested inspection (read-only) - Go github.com/apptainer/apptainer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/apptainer/apptainer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j3rw-fx6g-q46j (GitHub-reviewed advisory GHSA-j3rw-fx6g-q46j lists affected ranges: Go github.com/apptainer/apptainer >=0 <1.4.5) Commands are suggestions: review each one before running it.
Loading voting…