OpenSTAManager has Authenticated SQL Injection in API via 'display' parameter
CVE-2025-65103GHSA-2jm2-2p35-rp3j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (devcode-it/openstamanager 2.9.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist devcode-it/openstamanager
- Affected
- <= 2.9.4
- Fixed in
- 2.9.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2jm2-2p35-rp3j lists affected ranges: Packagist devcode-it/openstamanager >=0 <=2.9.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-65103: 0.37% estimated exploitation activity in the next 30 days; percentile 30.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authenticated SQL Injection vulnerability in the API allows any user, regardless of permission level, to execute arbitrary SQL queries. By manipulating the display parameter in an API request, an attacker can exfiltrate, modify, or delete any data in the database, leading to a full system compromise. Details The vulnerability is located in the retrieve() method within src/API/Manager.php. User input from the display GET parameter is processed without proper validation. The code strips the surrounding brackets [], splits the string by commas, and then passes each resulting element directly into the selectRaw() function of the query builder. Since selectRaw() is designed to execute raw SQL expressions, it executes any malicious SQL code provided in the display parameter. PoC 1. Log in to an OpenSTAManager instance as any user. 2. Navigate to the user's profile page to obtain their personal API Token. 3. Use this API token to send a specially crafted GET request to the API…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2jm2-2p35-rp3j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-65103 Advisory: OpenSTAManager has Authenticated SQL Injection in API via 'display' parameter IDs: CVE-2025-65103, GHSA-2jm2-2p35-rp3j Record: https://patchnext.com/advisories/cve-2025-65103 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: devcode-it/openstamanager 2.9.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist devcode-it/openstamanager: affected <= 2.9.4; fixed in 2.9.5 ## Suggested inspection (read-only) - Packagist devcode-it/openstamanager: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on devcode-it/openstamanager. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2jm2-2p35-rp3j (GitHub-reviewed advisory GHSA-2jm2-2p35-rp3j lists affected ranges: Packagist devcode-it/openstamanager >=0 <=2.9.4) Commands are suggestions: review each one before running it.
Loading voting…