Skip to content

← Actionable
High, CVSS 8.2

Decidim's private data exports can lead to data leaks

CVE-2025-65017GHSA-3cx6-j9j4-54mp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (decidim 0.30.4; decidim-core 0.30.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems decidim

    Affected
    >= 0.30.0, < 0.30.4
    Fixed in
    0.30.4
  • RubyGems decidim-core

    Affected
    >= 0.30.0, < 0.30.4
    Fixed in
    0.30.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2025-65017: 0.31% estimated exploitation activity in the next 30 days; percentile 24.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Private data exports can lead to data leaks in cases where the UUID generation causes collisions for the generated UUIDs. The bug was introduced by #13571 and affects Decidim versions 0.30.0 or newer (currently 2025-09-23). This issue was discovered by running the following spec several times in a row, as it can randomly fail due to this bug: Run the spec as many times as needed to hit a UUID that converts to 0 through .toi. The UUID to zero conversion does not cause a security issue but the security issue is demonstrated with the following example. The following code regenerates the issue by assigning a predefined UUID that will generate a collision (example assumes there are already two existing users in the system): Expect to see an error in the situation. Now, login as user with ID 1, go to /downloadyourdata, click "Download file" from the export and expect to see the data that should be attached to user with ID 2. This is an artificially replicated situation with the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3cx6-j9j4-54mp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-65017

Advisory: Decidim's private data exports can lead to data leaks
IDs: CVE-2025-65017, GHSA-3cx6-j9j4-54mp
Record: https://patchnext.com/advisories/cve-2025-65017 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: decidim 0.30.4; decidim-core 0.30.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems decidim: affected >= 0.30.0, < 0.30.4; fixed in 0.30.4
- RubyGems decidim-core: affected >= 0.30.0, < 0.30.4; fixed in 0.30.4

## Suggested inspection (read-only)
- RubyGems decidim: check the installed version with your package manager.
- RubyGems decidim-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on decidim, decidim-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3cx6-j9j4-54mp (GitHub-reviewed advisory GHSA-3cx6-j9j4-54mp lists affected ranges: RubyGems decidim-core >=0.30.0 =0.30.0 <0.30.4)

Commands are suggestions: review each one before running it.

Loading voting…