Skip to content

← Actionable
Critical, CVSS 9.1amended

@hpke/core reuses AEAD nonces

CVE-2025-64767GHSA-73g8-5h73-26h4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hpke/core 1.7.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-64767: 0.23% estimated exploitation activity in the next 30 days; percentile 13.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The public SenderContext Seal() API has a race condition which allows for the same AEAD nonce to be re-used for multiple Seal() calls. This can lead to complete loss of Confidentiality and Integrity of the produced messages. Details The SenderContext Seal() implementation allows for concurrent executions to trigger computeNonce() with the same sequence number. This results in the same nonce being used in the suite's AEAD. PoC This code reproduces the issue (and also checks for more things that could be wrong with the implementation). Recommendation Implement a synchronization mechanism such that only one seal()/open() per context can be executed at a time. Notes Refs: https://github.com/hpkewg/hpke/issues/38 https://www.rfc-editor.org/rfc/rfc9180.html#section-9.7.5 The AEADs specified in this document are not secure in case of nonce reuse. https://www.rfc-editor.org/rfc/rfc9180.html#section-5-6 A context is an implementation-specific structure that encodes the AEAD algorithm…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-73g8-5h73-26h4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-73g8-5h73-26h4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-73g8-5h73-26h4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64767

Advisory: @hpke/core reuses AEAD nonces
IDs: CVE-2025-64767, GHSA-73g8-5h73-26h4
Record: https://patchnext.com/advisories/cve-2025-64767 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @hpke/core 1.7.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @hpke/core: affected <= 1.7.4; fixed in 1.7.5

## Suggested inspection (read-only)
- `npm ls @hpke/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @hpke/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-73g8-5h73-26h4 (GitHub-reviewed advisory GHSA-73g8-5h73-26h4 lists affected ranges: npm @hpke/core >=0 <=1.7.4)
- Verified: https://osv.dev/vulnerability/GHSA-73g8-5h73-26h4 (OSV record GHSA-73g8-5h73-26h4 lists affected ranges: npm @hpke/core >=0 <1.7.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…