Skip to content

← Actionable
High, CVSS 7.1amended

Astro vulnerable to reflected XSS via the server islands feature

CVE-2025-64764GHSA-wrwg-2hg8-v723

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (astro 5.15.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm astro

    Affected
    <= 5.15.6
    Fixed in
    5.15.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N
EPSS
  • CVE-2025-64764: 0.53% estimated exploitation activity in the next 30 days; percentile 44.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary After some research it appears that it is possible to obtain a reflected XSS when the server islands feature is used in the targeted application, regardless of what was intended by the component template(s). Details Server islands run in their own isolated context outside of the page request and use the following pattern path to hydrate the page: /server-islands/[name]. These paths can be called via GET or POST and use three parameters: - e: component to export - p: the transmitted properties, encrypted - s: for the slots Slots are placeholders for external HTML content, and therefore allow, by default, the injection of code if the component template supports it, nothing exceptional in principle, just a feature. This is where it becomes problematic: it is possible, independently of the component template used, even if it is completely empty, to inject a slot containing an XSS payload, whose parent is a tag whose name is is the absolute path of the island file. Enabling…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wrwg-2hg8-v723

  2. Revision 1 · created ·

    Published from osv record GHSA-wrwg-2hg8-v723

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64764

Advisory: Astro vulnerable to reflected XSS via the server islands feature
IDs: CVE-2025-64764, GHSA-wrwg-2hg8-v723
Record: https://patchnext.com/advisories/cve-2025-64764 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: astro 5.15.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm astro: affected <= 5.15.6; fixed in 5.15.8

## Suggested inspection (read-only)
- `npm ls astro --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on astro.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wrwg-2hg8-v723 (OSV record GHSA-wrwg-2hg8-v723 lists affected ranges: npm astro >=0 <5.15.8 (fixed))
- Verified: https://github.com/advisories/GHSA-wrwg-2hg8-v723 (GitHub-reviewed advisory GHSA-wrwg-2hg8-v723 lists affected ranges: npm astro >=0 <=5.15.6)

Commands are suggestions: review each one before running it.

Loading voting…