Skip to content

← Actionable
High, CVSS 7.5

OpenBao is Vulnerable to Privileged Operator Identity Group Root Escalation

CVE-2025-64761GHSA-7ff4-jw48-3436

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openbao/openbao 2.4.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-64761: 0.39% estimated exploitation activity in the next 30 days; percentile 33.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Similar to HCSEC-2025-13 / CVE-2025-5999, a privileged operator could use the identity group subsystem to add a root policy to a group identity group, escalating their or another user's permissions in the system. Specifically this is an issue when: 1. An operator in the root namespace has access to identity/groups endpoints. 2. An operator does not have policy access. Otherwise, an operator with policy access could create or modify an existing policy to grant root-equivalent permissions through the sudo capability. Patches Patched in version 2.4.4. Workarounds Users should audit the use of identity subsystem and deny operators access if it is not in use.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7ff4-jw48-3436

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64761

Advisory: OpenBao is Vulnerable to Privileged Operator Identity Group Root Escalation
IDs: CVE-2025-64761, GHSA-7ff4-jw48-3436
Record: https://patchnext.com/advisories/cve-2025-64761 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/openbao/openbao 2.4.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/openbao/openbao: affected < 2.4.4; fixed in 2.4.4

## Suggested inspection (read-only)
- Go github.com/openbao/openbao: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/openbao/openbao.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7ff4-jw48-3436 (GitHub-reviewed advisory GHSA-7ff4-jw48-3436 lists affected ranges: Go github.com/openbao/openbao >=0 <2.4.4)

Commands are suggestions: review each one before running it.

Loading voting…