glob CLI: Command injection via -c/--cmd executes matches with shell:true
CVE-2025-64756GHSA-5j98-mcp5-4vw2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (glob 11.1.0, 10.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm glob
- Affected
- >= 11.0.0, < 11.1.0>= 10.2.0, < 10.5.0
- Fixed in
- 11.1.0, 10.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5j98-mcp5-4vw2 lists affected ranges: npm glob >=11.0.0 =10.2.0 <10.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5j98-mcp5-4vw2 lists affected ranges: npm glob >=11.0.0 =10.2.0 <10.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-64756: 3.09% estimated exploitation activity in the next 30 days; percentile 87.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The glob CLI contains a command injection vulnerability in its -c/--cmd option that allows arbitrary command execution when processing files with malicious names. When glob -c <command <patterns is used, matched filenames are passed to a shell with shell: true, enabling shell metacharacters in filenames to trigger command injection and achieve arbitrary code execution under the user or CI account privileges. Details Root Cause: The vulnerability exists in src/bin.mts:277 where the CLI collects glob matches and executes the supplied command using foregroundChild() with shell: true: Technical Flow: 1. User runs glob -c <command <pattern 2. CLI finds files matching the pattern 3. Matched filenames are collected into an array 4. Command is executed with matched filenames as arguments using shell: true 5. Shell interprets metacharacters in filenames as command syntax 6. Malicious filenames execute arbitrary commands Affected Component: - CLI Only: The vulnerability affects only…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5j98-mcp5-4vw2
- Revision 1 · created ·
Published from osv record GHSA-5j98-mcp5-4vw2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64756 Advisory: glob CLI: Command injection via -c/--cmd executes matches with shell:true IDs: CVE-2025-64756, GHSA-5j98-mcp5-4vw2 Record: https://patchnext.com/advisories/cve-2025-64756 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: glob 11.1.0, 10.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm glob: affected >= 11.0.0, < 11.1.0; >= 10.2.0, < 10.5.0; fixed in 11.1.0, 10.5.0 ## Suggested inspection (read-only) - `npm ls glob --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on glob. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5j98-mcp5-4vw2 (OSV record GHSA-5j98-mcp5-4vw2 lists affected ranges: npm glob >=11.0.0 =10.2.0 <10.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5j98-mcp5-4vw2 (GitHub-reviewed advisory GHSA-5j98-mcp5-4vw2 lists affected ranges: npm glob >=11.0.0 =10.2.0 <10.5.0) Commands are suggestions: review each one before running it.
Loading voting…