Directus Vulnerable to Information Leakage in Existing Collections
CVE-2025-64749GHSA-cph6-524f-3hgr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.13.0; @directus/api 32.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- < 11.13.0
- Fixed in
- 11.13.0
npm @directus/api
- Affected
- < 32.0.0
- Fixed in
- 32.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cph6-524f-3hgr lists affected ranges: npm directus >=0 =0 <32.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cph6-524f-3hgr lists affected ranges: npm directus >=0 =0 <32.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-64749: 0.35% estimated exploitation activity in the next 30 days; percentile 28.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary: An observable difference in error messaging was found in the Directus REST API. The /items/{collection} API returns different error messages for these two cases: 1. A user tries to access an existing collection which they are not authorized to access. 2. A user tries to access a non-existing collection. The two differing error messages leak the existence of collections to users which are not authorized to access these collections. Details: The following response returns an error message, when requesting a collection the user is not authorized to access. The following response returns a different error message when requesting a collection which does not exist. Impact: The difference in errors between non-existent collections and collections blocked by permissions leak the existence of a collection to a user which is not authorized to access this object. Credit: Sebastian Krause - Hackmanit GmbH
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cph6-524f-3hgr
- Revision 1 · created ·
Published from osv record GHSA-cph6-524f-3hgr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64749 Advisory: Directus Vulnerable to Information Leakage in Existing Collections IDs: CVE-2025-64749, GHSA-cph6-524f-3hgr Record: https://patchnext.com/advisories/cve-2025-64749 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 11.13.0; @directus/api 32.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected < 11.13.0; fixed in 11.13.0 - npm @directus/api: affected < 32.0.0; fixed in 32.0.0 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @directus/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus, @directus/api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cph6-524f-3hgr (OSV record GHSA-cph6-524f-3hgr lists affected ranges: npm directus >=0 =0 <32.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-cph6-524f-3hgr (GitHub-reviewed advisory GHSA-cph6-524f-3hgr lists affected ranges: npm directus >=0 =0 <32.0.0) Commands are suggestions: review each one before running it.
Loading voting…