Skip to content

← Actionable
Medium, CVSS 6.5amended

Directus's conceal fields are searchable if read permissions enabled

CVE-2025-64748GHSA-8jpw-gpr4-8cmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.13.0; @directus/api 32.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-64748: 0.30% estimated exploitation activity in the next 30 days; percentile 22.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability allows authenticated users to search concealed/sensitive fields when they have read permissions. While actual values remain masked (), successful matches can be detected through returned records, enabling enumeration attacks on sensitive data. Details The system permits search operations on concealed fields in the directususers collection, including token, tfasecret, password. Matching records are returned with masked values, but their presence confirms the searched value exists. The "Recommended Defaults" for "App Access" grant users full read permissions to their role/user records, inadvertently enabling them to search for any user's tokens, TFA secrets, and password hashes. Attackers can leverage known password hashes from breach databases to identify accounts with compromised passwords. Impact This vulnerability enables: - Token enumeration - Verification of valid authentication tokens - Password hash matching - Identification of accounts using known…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8jpw-gpr4-8cmh

  2. Revision 1 · created ·

    Published from osv record GHSA-8jpw-gpr4-8cmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64748

Advisory: Directus's conceal fields are searchable if read permissions enabled
IDs: CVE-2025-64748, GHSA-8jpw-gpr4-8cmh
Record: https://patchnext.com/advisories/cve-2025-64748 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.13.0; @directus/api 32.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 11.13.0; fixed in 11.13.0
- npm @directus/api: affected < 32.0.0; fixed in 32.0.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @directus/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus, @directus/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8jpw-gpr4-8cmh (OSV record GHSA-8jpw-gpr4-8cmh lists affected ranges: npm directus >=0 =0 <32.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8jpw-gpr4-8cmh (GitHub-reviewed advisory GHSA-8jpw-gpr4-8cmh lists affected ranges: npm directus >=0 =0 <32.0.0)

Commands are suggestions: review each one before running it.

Loading voting…