Directus is Vulnerable to Stored Cross-site Scripting
CVE-2025-64747GHSA-vv2v-pw69-8crf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- < 11.13.0
- Fixed in
- 11.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vv2v-pw69-8crf lists affected ranges: npm directus >=0 <11.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vv2v-pw69-8crf lists affected ranges: npm directus >=0 <11.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2025-64747: 0.26% estimated exploitation activity in the next 30 days; percentile 18.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored cross-site scripting (XSS) vulnerability exists that allows users with upload files and edit item permissions to inject malicious JavaScript through the Block Editor interface. Attackers can bypass Content Security Policy (CSP) restrictions by combining file uploads with iframe srcdoc attributes, resulting in persistent XSS execution. Details The vulnerability arises from insufficient sanitization in the Block Editor interface when processing JSON content containing HTML elements. The attack requires two permissions: - upload files - To upload malicious JavaScript files - edit item - To create or modify content with the Block Editor Attack Vector: 1. JavaScript File Upload: Attackers upload a malicious JavaScript file via the files endpoint, obtaining a file ID accessible through the assets directory 2. Block Editor Exploitation: Using a JSON field with Block Editor interface, attackers inject raw HTML containing an iframe with srcdoc attribute that references the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vv2v-pw69-8crf
- Revision 1 · created ·
Published from osv record GHSA-vv2v-pw69-8crf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64747 Advisory: Directus is Vulnerable to Stored Cross-site Scripting IDs: CVE-2025-64747, GHSA-vv2v-pw69-8crf Record: https://patchnext.com/advisories/cve-2025-64747 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 11.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected < 11.13.0; fixed in 11.13.0 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vv2v-pw69-8crf (OSV record GHSA-vv2v-pw69-8crf lists affected ranges: npm directus >=0 <11.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vv2v-pw69-8crf (GitHub-reviewed advisory GHSA-vv2v-pw69-8crf lists affected ranges: npm directus >=0 <11.13.0) Commands are suggestions: review each one before running it.
Loading voting…