js-yaml has prototype pollution in merge (<<)
CVE-2025-64718GHSA-mh29-5h37-fv8m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (js-yaml 4.1.1, 3.14.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm js-yaml
- Affected
- >= 4.0.0, < 4.1.1< 3.14.2
- Fixed in
- 3.14.2, 4.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mh29-5h37-fv8m lists affected ranges: npm js-yaml >=4.0.0 =0 <3.14.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mh29-5h37-fv8m lists affected ranges: npm js-yaml >=4.0.0 =0 <3.14.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2025-64718: 0.42% estimated exploitation activity in the next 30 days; percentile 36.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In js-yaml 4.1.0, 4.0.0, and 3.14.1 and below, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (proto). All users who parse untrusted yaml documents may be impacted. Patches Problem is patched in js-yaml 4.1.1 and 3.14.2. Workarounds You can protect against this kind of attack on the server by using node --disable-proto=delete or deno (in Deno, pollution protection is on by default). References https://cheatsheetseries.owasp.org/cheatsheets/PrototypePollutionPreventionCheatSheet.html
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mh29-5h37-fv8m
- Revision 1 · created ·
Published from osv record GHSA-mh29-5h37-fv8m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64718 Advisory: js-yaml has prototype pollution in merge (<<) IDs: CVE-2025-64718, GHSA-mh29-5h37-fv8m Record: https://patchnext.com/advisories/cve-2025-64718 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: js-yaml 4.1.1, 3.14.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm js-yaml: affected >= 4.0.0, < 4.1.1; < 3.14.2; fixed in 3.14.2, 4.1.1 ## Suggested inspection (read-only) - `npm ls js-yaml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on js-yaml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mh29-5h37-fv8m (OSV record GHSA-mh29-5h37-fv8m lists affected ranges: npm js-yaml >=4.0.0 =0 <3.14.2 (fixed)) - Verified: https://github.com/advisories/GHSA-mh29-5h37-fv8m (GitHub-reviewed advisory GHSA-mh29-5h37-fv8m lists affected ranges: npm js-yaml >=4.0.0 =0 <3.14.2) Commands are suggestions: review each one before running it.
Loading voting…